Intégrer une somme comme "valeur_si_vrai" d'une fonction SI [Résolu/Fermé]

Signaler
-
 Julien -
Bonjour,

Je suis à la recherche de l'écriture d'une formule.

Explication :
Ma cellule B20 comporte une liste déroulante. Selon le mot que je choisis dans cette liste, la cellule C20 affiche le résultat "7" avec la formule SI(B20="Berserker";"7";"")

Je voudrais ajouter une fonction SOMME à la place du "7" dans la formule ci-dessus pour prendre en compte le chiffre noté en D20.

Est-ce possible déjà ? Si oui, comment écrire cela ? J'ai essayé ceci mais sans succès:
SI(B20="Berserker";"D20+7";"") et aussi
SI(B20="Berserker";"=D20+7";"")

J'espère m'être correctement expliqué. Merci d'avance pour votre aide !


3 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
509
Bonjour,

Tu peux essayer
=SI(B20="Berserker";D20+7;"")

A+
Messages postés
53142
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 janvier 2021
15 121
Bonjour Julien.

Dans Excel, ce que tu écris entre guillemets est traité comme du texte.
Donc tes formules
SI(B20="Berserker";"D20+7";"") et
SI(B20="Berserker";"=D20+7";"")
ne peuvent en aucune manière donner un résultat !
Essaie la formule de Gyrus :
SI(B20="Berserker";D20+7;0)

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
C'est bien les guillemets qui posaient problème ! La formule de Gyrus fonctionne très bien ! Merci beaucoup pour votre aide !