Recherche de la valeur la plus récente antérieure à une date

Fermé
GDGDGDGD - 30 avril 2016 à 11:48
 GDGDGDGD - 30 avril 2016 à 23:20
Bonjour,

J'ai un tableau contenant trois colonnes

Date RunTime ResultatTest
1 24 350
2 23
3 24 210
4 22
5 24 125

La valeur ResultatTest n'est pas renseignée chaque jour.

Je voudrais trouver une formule Excel =F(DateDemandée) qui prend en argument une date et retourne la valeur de ResultatTest la plus récente connue à cette date.
Dans mon exemple on aurait:

F(1)= 350
F(2)= 350
F(3)= 210
F(4)= 210
F(5)= 125

Je saurais le faire en VBA mais j'aimerais éviter.
Je pourrais aussi rentrer dans la colonne ResultatTest le test de la veille à défaut d'en avoir une pour le journée même, mais j'aimerais aussi éviter pour des questions de taille de fichier.

Merci d'avance pour vos conseils

Gabriel

3 réponses

Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023 1 762
30 avril 2016 à 14:45
Bonjour,

Avec un colonne supplémentaire, en D2 :
=SI(ESTVIDE(C2);D1;C2)
à tirer vers le bas, puis pour F(Date) :
=INDEX(D:D;EQUIV(Date;A:A;0))
0
via55 Messages postés 14032 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 janvier 2023 2 548
30 avril 2016 à 14:59
Bonjour Gabriel
Bonjour Patrice

Avec une formule matricielle :
http://www.cjoint.com/c/FDEm6XaBkU4

Cdlmnt
Via
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023 1 762
30 avril 2016 à 15:34
Bonjour,

Bien vu, mais la formule n'a pas besoin d'être matricielle, il suffit que 9^9 soit supérieur au plus grand résultat de test !

Cdlt
Patrice
0
via55 Messages postés 14032 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 27 janvier 2023 2 548 > Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023
30 avril 2016 à 16:42
Re,

Oui c'est vrai, je me suis laissé emporter !

Cdlmnt
Via
0
Splendide. Merci beaucoup à tous!
Décidément plus on avance avec Excel plus on arrive à se passer de VBA.

Bonne soirée

Gabriel
0
Mais, dernier détail: le "C1:C" dans la formule la rend peu robuste vis-à vis des modifications de structure du classeur. Si on insère une nouvelle colonne la formule ne fonctionne plus.

Est-ce irrémédiable à votre avis?

Merci

Gabriel
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 janvier 2023 1 762
30 avril 2016 à 18:34
Re,

«Est-ce irrémédiable à votre avis? »
Non, tu peux utiliser :
=INDEX(C:C;EQUIV(9^9;DECALER(C1;0;0;EQUIV(4;A:A;0))))
0
Bravo et merci pour cette aide précieuse et rapide.
Passez une bonne soirée

Gabriel
0