Mise en Forme conditionnelle : Valeur entre (négatif) [Résolu/Fermé]

Signaler
Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016
-
Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016
-
Bonjour,

J'aimerais mettre une mise en forme conditionnelle sur un pourcentage, mais je ne suis pas capable. Quel est le moyenne automatique pour arrive à ma fin.

Vert : -10% et moins
Jaune : -10% à 10%
Rouge : 10% et plus


Merci

2 réponses

Messages postés
26072
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 juin 2021
5 961
Bonjour
vous pouvez appliquer trois MFC par formule
ex pour cellule A1

pour vert:
=A1<=-0,1
pour jaune
=ET(A1>-0,1;A1<0,1
pour rouge
A1>=0,1

pour MFC par formule:
_ _sélection du champ / Accueil / Mise en forme; conditionnelle
_ _"nouvelle règle"
_ _utiliser une formule pour....
_ _entrer la formule
_ _format formater / OK
_ _retour à la fenêtre de formulation, cliquer sur nouvelle régle
etc...
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016

J'ai vu mon erreur j'écrivais -0.1 au lieux de -0,1


Maintenant, je veux que la valeur en pourcentage produit une donnée automatique dans la colonne d'après.


40% et plus : Très élevé
10% à 40% : Élevé
...

ex :

48% Très élevée
6% Égale
Messages postés
26072
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 juin 2021
5 961
Re

=SI(A1>40%,"très élevé";SI(A1>10%; "élevé";"normal"))

crdlmnt
Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016

Ma formule ne fonctionne pas :

=SI(S4>0,4;"Très élevée");SI(S4>0,1%;"Élevé");SI(S4<0,1%;"Égale");SI(S4<-0,1;"Faible");SI(S4<-0,4;"Très faible")

J'ai essayé aussi de remplacer les valeurs 0.4 par 40% et ca ne fonctionne pas plus.
Messages postés
26072
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 juin 2021
5 961 >
Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016

Plusieurs erreur
1°) ne pas fermer chaque item par une parenthèse, fermer seulement à la fin par un nombre de parenthèses égal au nombre de SI
2°) des fois vous écrivez avec le signe % des fois sans, il faut choisir, soit 0,4 ou 0,1 ou 40% ou 10%, maisz si vous écrivez 0,1%, cela n'a plus la même valeur, mais correspond à 0,0001
3°) à la fin de la formule il faut inverser les trois items <, car si par exemple S4 est égal à -0,5, il va être détecté comme plus petit que 0,1 et c'est "Egale" qui sera affiché, car Excel arrête de lire dès qu'une condition est remplie
4° il vaut mieux rajouter une condition qui renvoie une cellule blanche quand S4 est vide, sinon vous aurez droit à Egale

=SI(S4="";"";SI(S4>0,4;"Très élevée";SI(S4>0,1;"Élevé";SI(S4<-0,4;"Très faible";SI(S4<-0,1;"Faible";SI(S4<0,1;"Egale"))))))

crdlmnt
Messages postés
4
Date d'inscription
mercredi 20 avril 2016
Statut
Membre
Dernière intervention
20 avril 2016

Merci tu m'as sauvé la vie :)