Afficher smiley de couleur en fonction de valeur de cellule

Résolu/Fermé
Kikochikitin Messages postés 2 Date d'inscription jeudi 14 avril 2016 Statut Membre Dernière intervention 14 avril 2016 - Modifié par Kikochikitin le 14/04/2016 à 10:43
 Stephanie - 15 août 2016 à 21:21
Bonjour à tous,
je pose ici une question sur un thème déjà abordé sur le forum, mais je n'ai pas réussi à adapter les solutions proposées aux autres utilisateurs:

Dans la ligne 4 colonne AV, je rentre une valeur comprise entre 1 et 10
Dans la ligne 4 colonne I, j'aimerai que la valeur précédemment rentrée renvoie à:
- un smiley vert qui sourit si valeur AV comprise entre 1 compris et 4 compris
- un smiley orange bouche à plat si valeur AV comprise entre 5 compris et 7 compris
- un smiley rouge bouche à l'envers si valeur AV comprise entre 8 compris et 10 compris compris et 5 compris

Une fois cette opération effectuée, je voudrai pouvoir dérouler verticalement ma formule.

En vous remerciant par avance

http://www.cjoint.com/c/FDoiL3lfVuJ

2 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 283
Modifié par Vaucluse le 14/04/2016 à 10:59
Bonjour

vous ne pouvez pas (du moins de ce que je sais)utiliser directement des icones ailleurs que dans la cellule qui contient la condition (Soit AV dans votre cas)

essayez ceci si c'est possible:

format du champ I > police Wingsdings (taille à la demande)
formule en I4

=SI(AV4="";"";SI(AV4<=4;"J";SI(AV4<=7;"K";"L")
(lettres majuscules)

et pour les couleurs , passer par une MFC par formules avec
I4="J" ou I4="K" ou I4="L"

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 851
14 avril 2016 à 17:14
Bonjour Vaucluse,

sur ce site : https://answers.microsoft.com/fr-fr/office/forum/office_2010-excel/cr%C3%A9er-des-jeux-dic%C3%B4ne-pour-excel/500da856-6167-e011-8dfc-68b599b31bf5?auth=1

il est proposé de mettre un format numérique personnalisé : [Rouge][>7]"L"; [Vert][<5]"J"; [Jaune]"K"; @

ça peut être une alternative à une MFC.

cordialement
0
Kikochikitin > JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020
15 avril 2016 à 00:52
j'ai essayé la formule indiquée, [Rouge][>7]"L"; [Vert][<5]"J"; [Jaune]"K"; @ elle génère une erreur.

Comme indiqué par ailleurs, ce n'est pas grave pour la couleur!!!

Merci malgré tout pour les informations!!!
0
JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 851
15 avril 2016 à 05:25
Bonjour,

Je n'ai pas parlé de formule mais de format personnalisé.

Cdlt
0
Comment faire pour mettre un emoji on couleur sur snapchat
0