Formules pour calculer temps et moyenne [Résolu/Fermé]

Signaler
Messages postés
2854
Date d'inscription
dimanche 22 mai 2005
Statut
Membre
Dernière intervention
29 octobre 2020
-
Messages postés
25463
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
-
Bonjour,

Excel 2010

Pouvez vous me dire quelle formule pour calculer la moyenne du total des colonnes (A & B) - "70 km".

Merci

Voir screen

https://www.cjoint.com/c/FBcsOb1SRns


1 réponse

Messages postés
25463
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Bonjour ou plutôt re:

=SOMME(A2:B2)/C2/24

ou

=SOMME(A2:B2)/(C2*24)

formatez la cellule résultat en standard

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
2854
Date d'inscription
dimanche 22 mai 2005
Statut
Membre
Dernière intervention
29 octobre 2020
73
Bsr Vaucluse

Trop fort pour te piéger :-). Breffff c'est pas le but non plus.

Cependant, une fois la colonne sélectionnée pour cette nouvelle formule, j'ai droit (dans les cellules vides) au fameux "#DIV/0!", pffffffff.

J'ai bien regardé sur Google, dont j'ai vu une de tes interventions.
Mais ça me parait bien compliqué. Y'a pas "un truc" tout simple pour masquer ces "DIV"?

https://www.cjoint.com/c/FBculy1u2Vs
Messages postés
2854
Date d'inscription
dimanche 22 mai 2005
Statut
Membre
Dernière intervention
29 octobre 2020
73
Re Vaucluse

J'ai donc appliqué (après recherches sur Google), une mise en forme conditionnelle (couleur de police blanche) sur la plage de cellules concernées (qui doit être dépourvue de couleur, donc blanche), et ça fonctionne.

Seul dommage, c'est que cette plage ne peut être colorée. Je ferai avec.

Je ne t'explique rien Vaucluse, tu sais ça bien sûr. J'ai expliqué dans la mesure ou ça peut intéresser autrui.

Merci
Messages postés
25463
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565 >
Messages postés
2854
Date d'inscription
dimanche 22 mai 2005
Statut
Membre
Dernière intervention
29 octobre 2020

Bonjour

si tu as Excel au moins 2007, pour faire plus léger:

=SIERREUR(SOMME(A2:B2)/(C2*24));"")

Code SIERREUR(formule);"") évite l'affichage de code erreur quel qu'il soit.
et avant:

=SI(ESTERREUR(SOMME(A2:B2)/(C2*24));""; SOMME(A2:B2)/(C2*24))

ou encore dans tous les Excel

=SI(C2=0;"";SOMME(A2:B2)/(C2*24))

crdlmnt
Messages postés
2854
Date d'inscription
dimanche 22 mai 2005
Statut
Membre
Dernière intervention
29 octobre 2020
73
Bjr

La forme conditionnelle ne me plaisant pas, j'ai fouiné davantage et j'ai enfin compris la formule ""si(esterreur"" à noter avant la formule qui sert au calcul.

Donc j'ai bien appliqué TA 1ère formule sur TA 1ère réponse (en haut de page) et la faisant précéder de "si(esterreur"", et ça fonctionne.

Ce qui donne pour moi la formule suivante :

=SI(ESTERREUR(SOMME(H19:K19)/N19/24);"";SOMME(H19:K19)/N19/24)

C'est pas tjrs simple lorsqu'on n'y connait rien. C'est tellement complexe ces formules ; un signe et ça déraille.

Breffff, merci Vaucluse, bonne journée

PS : C'est bête parce que ce message donne une solution pour contrer les "DIV/0!", alors que ce n'est pas le sujet initial. De fait il ne sera ptet pas vu par quelqu'un qui recherche cette solution.
Messages postés
25463
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
5 565
Pas grave le PS, il y aura toujours quelqu'un pour répondre..... à ceux qui n'ont pas le courage de chercher sur le site les nombreux fils qui en parlent!
Bonne route
Bien cordialement