Trouver si des mots sont présents dans une cellule

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
lundi 1 février 2016
Statut
Membre
Dernière intervention
23 mai 2016
-
Messages postés
6
Date d'inscription
lundi 1 février 2016
Statut
Membre
Dernière intervention
23 mai 2016
-
Bonjour a tous !

Voila, je suis face a un problème dont je ne trouve pas la solution (c'est pourquoi je suis la).

J'ai dans une cellule A un texte. Je voudrais que dans une cellule B si la cellule A contient une chaine de mots X ou Y ou Z...alors ma cellule note OUI sinon NON.

Merci beaucoup de votre aide. Et n'hésitez pas a me signaler si il manque des éléments dans mon ennonce.

3 réponses

Messages postés
5704
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
26 octobre 2021
667
Bonjour

Essayer ceci

=SI(OU(CHERCHE("*"&A3&"*";$A$1;1)=1;CHERCHE("*"&A4&"*";$A$1;1)=1;CHERCHE("*"&A5&"*";$A$1;1)=1);1;0)

Le texte à contrôler est dans une cellule ici A3, A4, A5
A3 = avant
A4 = après
A5 = dessus

Ou avec le texte dans la formule

remplacer 0 et 1 avec vos informations si oui ou non

=SI(OU(CHERCHE("*avant*";$A$1;1)=1;CHERCHE("*après*";$A$1;1)=1;CHERCHE("*dessus*";$A$1;1)=1);1;0)
Messages postés
6
Date d'inscription
lundi 1 février 2016
Statut
Membre
Dernière intervention
23 mai 2016

Bonjour bonjour,

Tout d'abord merci de la reponse rapide. C'est sympa.

En revanche la formule ne foncrtionne pas. Du coup j'affine mon ennonce.

En cellule H2 j'ai :
  • REFAIRE LA TIRETTE ET LA CLOCHETTE
  • FOURNIR UN CADENAS⇒FOURNI LE 16 DEC

En cellule H3 j'ai :
  • CHANGER LE TOURET CASSE

...

Je voudrais dans la colonne E un OUI si la cellule H contient le texte
"FOURNIR UN CADENAS" ou "CHANGER LE TOURET" ou...

Est il possible d'avoir une formule qui ne condamne pas plein de colonne car je risque d'avoir une dizaine de combinaison de texte possible ?

Et biensur NON si la cellule H ne contient aucune combinaison de mot.

Merci beaucoup de votre aide.

(j'utilise excel 2010 si ca peut aider)
Messages postés
26248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2021
6 094
Bonjour

exemple à adapter
si vous avez une liste de texte entrée en A2:A100
et en H2:H10 une liste des textes à détecter:

en A2, la, formule:

=SI(SOMMEPROD((NB.SI(A2;"*"&$H$2:$H$10&"*"))*(A2<>""))>0;"OUI";"NON")

qui renverra OUI si A2 contient un des textes de H1:H10

attention aux signes de blocage aux bons endroits et notez que le code SOMMEPROD exige des N° de ligne dans les limites de champ(pas de H:H mais H1:H10 par ex)
____________________

une autre solution consisterait à appliquer des mises en forme de couleurs différentes sur les lignes à détecter, avec la formule:

=NB.SI(A1;"*"&$H$1&"*") et en affectant une couleur et une MFC par texte en H, ainsi à chaque ligne détectée, le tableau prend la couleur du texte trouvé



crdlmnt
Messages postés
6
Date d'inscription
lundi 1 février 2016
Statut
Membre
Dernière intervention
23 mai 2016

Merci, mais....Hum desole, mais ca ne marche toujours pas. :-(


J'ai un fichier avec exemple de phrase a rechercher

https://www.dropbox.com/s/e8x38hyuecgooxw/test%20excel.xlsx?dl=0

Merci beaucoup a vous tous
Messages postés
26248
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 octobre 2021
6 094
Bonjour

Voyez le fichier joint où j'ai placé deux options: en colonne B d'après les textes de DE et en colonne C d'après les textes de E

https://www.cjoint.com/c/FBdhmRI4kgf

ça ne peut fonctionner que si les textes cherchés sont exactement reportés dans la colonne A

FOURNIR UN CADENAS de D2 dans le fichier joint, renvoi bien OUI sur B6 par exemple

si vous voulez plus de résultat, il faut reprendre vos textes où en rajouter en allongeant le champ dans des références à trouver.

crdlmnt



Messages postés
6
Date d'inscription
lundi 1 février 2016
Statut
Membre
Dernière intervention
23 mai 2016

Sugoi comme on dit ici au Japon !!!!! traduction : super. Un grand grand grand grand merci à tous ! Super forum, super réactivité !