Convertir heure texte de divers format en heure Excel [Résolu/Fermé]

Signaler
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018
-
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018
-
Bonjour, je désire convertir un fichier heure texte en heure excel automatisé
j'ai essayé gauche, droite, cnum, si(), mais je n'arrive pas à l'automatiser
0sec
2min 3sec
10min 54sec
1h 22min 29sec
1h 0min 0sec
1h 22min 29sec

Merci au meilleur astucien !


2 réponses

Messages postés
2886
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2020
398
Bonjour,

Je ne suis pas le meilleur !

=SI(OU(TROUVE("m";H5)=2;TROUVE("m";H5)=3);"00:"&SUBSTITUE(SUBSTITUE(H5;"sec";"");"min";":");(SUBSTITUE(SUBSTITUE(SUBSTITUE(H5;"h";":");"sec";"");"min";":")))*1

le tout formater en heure
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018

Bonsoir, pas le meilleur, mais pas mal du tout

Sauf

0sec
1sec
5sec
52sec

Donne "valeur"

2min 3sec
10min 54sec
1h 22min 29sec
1h 0min 0sec
12h 22min 29sec

C'est OK
Messages postés
2886
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2020
398 >
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018

ok
je n'avais pas traiter ce cas la !
donc
=SI(DROITE(H5;3)="sec";"00:00:"&STXT(H5;1;NBCAR(H5)-3);SI(OU(TROUVE("m";H5)=2;TROUVE("m";H5)=3);"00:"&SUBSTITUE(SUBSTITUE(H5;"sec";"");"min";":");(SUBSTITUE(SUBSTITUE(SUBSTITUE(H5;"h";":");"sec";"");"min";":"))))*1
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018
>
Messages postés
2886
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
30 novembre 2020

Merci, mais il faut les deux formules, donc très longue
=SI(DROITE(H5;3)="sec";"00:00:"&STXT(H5;1;NBCAR(H5)-3);SI(OU(TROUVE("m";H5)=2;TROUVE("m";H5)=3);"00:"&SUBSTITUE(SUBSTITUE(H5;"sec";"");"min";":");(SUBSTITUE(SUBSTITUE(SUBSTITUE(H5;"h";":");"sec";"");"min";":"))))*1
pour
0sec
1sec
5sec
52sec

mais elle ne fonctionne plus pour

2min 3sec
10min 54sec
1h 22min 29sec
1h 0min 0sec
12h 22min 29sec
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018

Donc formule longue, mais fonctionnel

=SI(NBCAR(O5)<6;SI(DROITE(O5;3)="sec";"00:00:"&STXT(O5;1;NBCAR(O5)-3);SI(OU(TROUVE("m";O5)=2;TROUVE("m";O5)=3);"00:"&SUBSTITUE(SUBSTITUE(O5;"sec";"");"min";":");(SUBSTITUE(SUBSTITUE(SUBSTITUE(O5;"h";":");"sec";"");"min";":"))))*1;SI(OU(TROUVE("m";O5)=2;TROUVE("m";O5)=3);"00:"&SUBSTITUE(SUBSTITUE(O5;"sec";"");"min";":");(SUBSTITUE(SUBSTITUE(SUBSTITUE(O5;"h";":");"sec";"");"min";":")))*1)

ma cellule est en O5 pas en H5

je cherche plus court, mais c'est un bon début
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
822
Bonsoir à tous,

essaye
=1*(SI(ESTERREUR(CHERCHE("h ";G6));"0:";"")&SI(ESTERREUR(CHERCHE("min ";G6));"0:";"")&SUBSTITUE(SUBSTITUE(SUBSTITUE(G6;"h ";":");"min ";":");"sec";""))

avec ta date en G6

cordialement
Messages postés
20
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
21 juin 2018

JvDo merci super formule, qui fonctionne impeccablement bien

Très bonne astuce

=1*(SI(ESTERREUR(CHERCHE("h ";A1));"0:";"")&SI(ESTERREUR(CHERCHE("min ";A1));"0:";"")&SUBSTITUE(SUBSTITUE(SUBSTITUE(A1;"h ";":");"min ";":");"sec";""))

La date en A1

Bonne soirée


et merci à DjiDji59430 pour sa contribution