Recherche suivants deux critères

[Résolu/Fermé]
Signaler
-
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
-
Bonjour,

Je suis bloqué sur une recherche suivant deux critères.

Je cherche à extraire d'un tableau A vers un tableau B, sur une autre feuille, une liste de clients (colonne A) suivant qu'ils remplissent deux conditions bien précises (colonne B et C).

Pour être plus concret, dans un tableau sur une feuille 1 j'ai une liste de clients facturés à la tâche ou au forfait, mensuellement ou trimestriellement. Sur une feuille 2, j'ai besoin de ne faire apparaître que les clients étant facturés à la tâche et mensuellement.

Comment faire svp?

J'ai testé pas mal de truc déjà présent sur ce forum mais rien qui ne convienne à mon problème.

Merci d'avance.

2 réponses

Messages postés
5693
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
15 octobre 2021
663
Bonjour

Pour une rechercheV avec 2 critères en principe il faut concaténer les 2 informations dans une colonne
exemple =A1&" "&B1
et on se sert de cette colonne pour faire la recherche

Un exemple de votre fichier serait le bienvenu pour nous aider à vous aider
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Bonsoir
dans tous les cas, RECHERCHEV ne vous renverra pas une liste, mais uniquement la première valeur trouvée dans la base de données
voyez si vous pouvez tirer quelque chose de ce modèle, sachant qu'il utilise la colonne G de BDD pour identifier et incrémenter les lignes à ressortir en feuille édition
Dans votre cas, la colonne G devra contenir une formule du genre:

=SI(ET(A2="xxx";B2="zzz");MAX($G$1:G1)+1);"")
revenez si besoin d'aide pour ma mettre en place

https://www.cjoint.com/c/FAlsFSqT6sl

crdlmnt


Il est souvent plus facile de trouver la réponse que de comprendre la question
Bonjour Vaucluse,

Merci pour ton aide j'ai réussi à faire ce que je voulais grâce à tes conseils.

Cordialement
Messages postés
26227
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 octobre 2021
6 085
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt