NB SI multi critères

[Résolu/Fermé]
Signaler
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,
dans une cellule je peux avoir soit :
-non détecté,<1
-détecté,<1
-1

j'aimerais avoir dans une autre cellule en fonction de la première:
-ND
-<
-(vide)

j'ai commencé comme ça mais ça ne marche qu'avec un critère (j'aimerais rajouté le deuxième)...
=SI(NB.SI(H7;"*non*");"ND";"")

Ensuite est il possible si j'ai "non détecté,<1" ou "détecté, <1" ne garder que le chiffre?

Merci


4 réponses

Messages postés
10129
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
27 septembre 2021
2 211
Bonjour

Essaies ceci (ta valeur en A2
=SI(NB.SI(A2;"*non*");"ND";SI(NB.SI(A2;"*détecté*");"<";""))

Pour
Ensuite est il possible si j'ai "non détecté,<1" ou "détecté, <1" ne garder que le chiffre?
je ne comprends pas où tu veux en venir

Cdlmnt
Cool la formule fonctionne merci.
Messages postés
3561
Date d'inscription
mercredi 11 février 2009
Statut
Contributeur
Dernière intervention
27 septembre 2021
189
Pour le problème décrit, je n'ai pas l'impression que la fonction NB.SI() soit la solution : elle ne fait que compter le nombre de fois qu'une condition est vraie dans un ensemble sélectionné.

La fonction SI() semble beaucoup plus adaptée, comme tu le pensais déjà.

Il faudrait la tourner comme cela (en partant du principe que la première cellule est en H7 comme ton exemple le fait croire) :

=SI(H7 = "non détecté, <1";"ND";SI(H7 = "détecté, <1";"<";""))

Cela suppose également qu'il ne peut y avoir que ces trois valeurs, autrement il faudra imbriquer un nouveau SI() pour gérer les cas "autres".

Pour la deuxième question, la fonction DROITE() devrait faire son office :)
Ok merci, mais la fonction droite ne va pas allé, je peux avoir des décimale parfois 1 2 ou 3 chiffre après la virgule... j aimerais garder uniquement le numérique et retirer les textes et symbole.
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
Bonjour


=SI(NB.SI(H7;"*non*");"ND";SI(NB.SI(H7;"*<*");"<";""))

et que veux dire ne garder que le 1? dans quel cas, avec le ND, sans le ND?

à vous lire

crdlmnt
Dans tous les cas... en fait j ai une cellule avec l'un des trois cas de figure (le chiffre varie ça peu être avec 1 2 ou 3 décimale).
Je souhaite mettre en forme des résultats en 2 colonnes avec dans la première ND, > ou rien donc ça c est résolu et dans la deuxième colonne ne garder que le chiffre

ex: colonne A :

non détécté, <0.26
détecté, <0.9
13.1

colonne B :

ND
<
"vide"

colonne C :
0.26
0.9
13.1

Voila j’espère que c'est clair...
C'est bon j'ai réussi. Merci à tous pour votre aide.
Pour retirer le texte j'ai fais une petite macro avec des "remplacer" (détecté par rien)
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 066
A toutes fins utiles par formule:

=SI(ESTERREUR(TROUVE("<";A1));A1;STXT(A1;TROUVE("<";A1)+1;10))

crdlmnt