Fonction logique SI [Résolu/Fermé]

Signaler
-
Messages postés
3175
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
5 mai 2021
-
Bonjour,
Dans mon tableau excel, j'ai deux colonnes A et B dont les cellules de A contiennent les dates de 1 au 30 et celles de B contiennent leur équivalence en jours, je désire les identifier dans la colonne C par leur nature ou type à savoir "Jour ouvrable", "jour Férié" ou "Week End" en se basant sur la la fonction SI. Quand j'utilise la fonction =SI(OU(A1="01 01 2015";B1="Sam";B1="Dim");"Jour Férié";"Jour Ouvrable". le resultat se traduit par FAUX. Je vous prie de m'indiquer une solution et merci.


1 réponse

Messages postés
3175
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
5 mai 2021
444
Bonjour,

=SI(OU(A1=date(2015;01;01);B1="Sam";B1="Dim");"Jour Férié";"Jour Ouvrable")

Et régulièrement, tu devrais avoir une liste des jours fériés nommée fériés (au hasard), et ta formule devient
=SI(OU(sierreur(recherchev(a1;fériés;0);0);B1="Sam";B1="Dim");"Jour Férié";"Jour Ouvrable") qui est alors valable pour tous les jours de l'année.