Synthèse de plusieurs feuilles

Résolu/Fermé
Mistral_13200 Messages postés 591 Date d'inscription mardi 5 août 2008 Statut Membre Dernière intervention 7 novembre 2021 - 27 nov. 2015 à 18:09
Boisgontierjacques Messages postés 175 Date d'inscription jeudi 19 septembre 2013 Statut Membre Dernière intervention 26 décembre 2018 - 28 nov. 2015 à 10:59
Bonjour à vous tous,
Pour les besoins d’un concours international, organisé par quatre clubs français j’ai besoin de réaliser la synthèse de quatre classements.

Dans un classeur je vais avoir les quatre classements, chacun sur un onglet différent. Dans chaque onglet j’ai une colonne avec un N° de référence et une autre avec le total obtenu. Le but est de synthétiser l’ensemble en additionnant les quatre totaux d’une même référence dans un cinquième onglet en les classant dans un ordre décroissant.
Le nombre de ligne sera identique pour les quatre classements mais peut varier entre 2500 et 3000 enregistrements.

Un lien pour un classeur test :
https://www.cjoint.com/c/EKBrgAtsCVm

En vous remerciant par avance de votre aide.

Cordialement.
Mistral

3 réponses

Mistral_13200 Messages postés 591 Date d'inscription mardi 5 août 2008 Statut Membre Dernière intervention 7 novembre 2021 4
28 nov. 2015 à 08:57
Bonjour,

Tout d'abord merci à toi de t'intéresser à mon problème.
Ta proposition ne correspond pas à mes attentes compte tenu que le fichier joint été trop succinct.
Avec le lien ci-dessous tu trouvera un fichier complet:
https://www.cjoint.com/c/EKChV5NP4Hm
Sur la feuille exemple tu trouveras toutes les explication, si toute fois tu souhaite toujours m'apporter ton aide.

Cordialement.
Mistral
1
Boisgontierjacques Messages postés 175 Date d'inscription jeudi 19 septembre 2013 Statut Membre Dernière intervention 26 décembre 2018 64
28 nov. 2015 à 10:59
>Ta proposition ne correspond pas à mes attentes compte tenu que le fichier joint été trop succinct.

La formule correspond au fichier joint.

Boisgontier
0
Boisgontierjacques Messages postés 175 Date d'inscription jeudi 19 septembre 2013 Statut Membre Dernière intervention 26 décembre 2018 64
Modifié par Boisgontierjacques le 27/11/2015 à 19:48
Bonsoir,

=SOMMEPROD(SOMME.SI(INDIRECT("'"&"classement"&LIGNE($1:$4)&"'!A4:A20");A4;INDIRECT("'"&"classement"&LIGNE($1:$4)&"'!B4:B20")))


http://boisgontierjacques.free.fr/pages_site/sommeprod3D.htm#Somme3DChamp


Boisgontier
0
Heas Messages postés 71 Date d'inscription samedi 21 novembre 2015 Statut Membre Dernière intervention 3 juillet 2018 4
27 nov. 2015 à 18:35
Bonjour,
je ne sais pas si j'ai saisi le problème, en tous cas une solution :

EN B2 Feuille synthèse :
=Classement1.B4+Classement2.B4+Classement3.B4+Classement4.B4

Copier sur le nombre de cellules désiré

Sélectionner la colonne B, faire un collage spécial (Copier les valeurs)en D par exemple, puis faire un tri.

Bon courage
-1