Petit problème avec les variables Session [Résolu/Fermé]

Signaler
Messages postés
536
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
8 octobre 2015
-
Messages postés
536
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
8 octobre 2015
-
Bonjour à tous,
J'ai un petit problème, ma variable session ne garde pas ca valeur ou je ne suis pas capable de l'afficher. je vais vous donner un exemle de mon code.

Page no 1
<?php
session_start();
session_register("variable1");
$_SESSION['variable1']="test test";
header('Location: login.php');
?>

Il y a seulement cela sur la page no 1.

Maintenant la page no 2 (qui est login.php)(tout en haut de la page, même pas un esace)

<?php
echo $_SESSION['variable1'];
?>
et ici je crée mes balise <html><head><title></title></head> ......

Le problème c'est quand je fait le ECHO, il serais supposer d'écrire "test test" mais rien ne s'affiche.

Est-ce que quelqu'un aurait une petite idée ??

Merci Beaucoup!!

Pascal_22

3 réponses

Il faut également mettre le session_start() sur ta seconde page ;)
Messages postés
536
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
8 octobre 2015
52
Salut renolipus,

Merci beaucoup ça fonctionner !! :)

Je croyais que session_start() devais être seulement sur la page qui active la variable SESSION.

Merci de ton coup de main !! ;)

Pascal_22
Messages postés
536
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
8 octobre 2015
52
La solution : il manquait sur ma page session_start() en haut de l page