Problème ssh entre un wyse et un debian [Fermé]

Signaler
Messages postés
5
Date d'inscription
vendredi 12 décembre 2014
Statut
Membre
Dernière intervention
27 mai 2016
-
Messages postés
29984
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 juillet 2021
-
Bonjour, voila dans le cadre d'un cours , on dois faire communiquer un wyse winter s50 (client) avec wyse linux v6 avec un debian ( serveur). Donc j'ai penser à utiliser le ssh pour tenter la connexion entre eux (ils se ping déjà bien entre eux) , mais le "programme" pour utiliser le ssh sur le wyse ne semble pas fonctionner avec les mêmes commandes que celles des linux classiques . Pouvez-vous m'aider ?
Cordialement,
Dovahki

1 réponse

Messages postés
29984
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
26 juillet 2021
7 141
Bonjour,

Le message en l'état est un peu vague. Peux-tu nous indiquer la commande que tu as tenté de lancer (côté client) et le résultat affiché ?

As-tu veillé aux points suivants ?

1) Sous debian, le serveur ssh refuse par défaut les connexions en root. Il faut donc te connecter avec un profil utilisateur. Par exemple si le login "toto" est défini sur le serveur, ta commande ssh devrait côté client ressembler à :

ssh toto@ip_du_serveur


2) Le serveur ssh est lancé sous debian :

service ssh start
service ssh status
netstat -ntlp


3) Le port sur lequel écoute le serveur et utilisé par le client sont cohérent (par défaut 22 dans les deux cas). Par exemple si le serveur écoute sur le port 2222 :

ssh -p 2222 toto@ip_du_serveur


4) Il n'y a pas de pare-feu entre le client et le serveur. Tu peux par exemple vérifier côté client avec la commande :

nmap ip_du_serveur


Exemple : ici je scanne ma propre machine et le ssh apparaît bien :

(mando@velvet) (~) $ nmap localhost

Starting Nmap 6.47 ( https://nmap.org/ ) at 2015-11-10 10:32 CET
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00015s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 995 closed ports
PORT STATE SERVICE
21/tcp open ftp
22/tcp open ssh
53/tcp open domain
631/tcp open ipp
8010/tcp open xmpp

Nmap done: 1 IP address (1 host up) scanned in 0.07 seconds


5) Utilise-tu des clés ssh et/ou as-tu changé le mode d'authentification côté serveur pour n'autoriser que les connexions par clé ssh ? Si oui tu devrais vérifier en mode verbose ce que raconte ssh côté client ;

ssh -vvv toto@ip_du_serveur


Bonne chance