Installation de honeyd [Résolu/Fermé]

Signaler
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015
-
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015
-
Bonjour,
svp quelqu'un m'aider à mon problème concernant l'installation de packetage honeyd
voila la problème
et mercii d'avance


5 réponses

Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021
7 124
Bonjour,

Si tu te réfères à ce qui est indiqué ici :
https://packages.debian.org/squeeze/net/honeyd

... le paquet honeyd n'est fourni qu'en wheezy et en sid (au moment où j'écris ton message). J'imagine que tu es probablement en train d'utiliser une autre version de debian (jessie ou stretch) comme en témoigne sans doute
/etc/apt/sources.list
.

Note qu'en ce moment : testing=stretch ou stable=jessie.

Du coup, la seule manière de l'installer consiste à activer les paquets sid quand ils ne sont pas dans ta version de debian. Cela signifie que nous allons configurer apt pour prendre en priorité les paquets de ta version de debian et le cas échéant le paquet sid=unstable.

Note également que conformément à cette page, il faudra activer les dépôts debports.
https://www.ports.debian.org/mirrors

Tout ce qui suit doit être fait en root.

1) Crée le fichier
/etc/apt/preferences
et écris dedans :

Package: *
Pin: release o=Debian,a=testing
Pin-priority: 990

Package: *
Pin: release o=Debian,a=unstable
Pin-priority: 90


(remplace au besoin testing par stable selon la version de debian que tu utilises, cf
/etc/apt/sources.list
)

2) Ajoute dans /etc/apt/sources.list les lignes correspondant aux dépôts sid.

Exemple :

deb http://ftp.fr.debian.org/debian/ testing main contrib non-free
deb https://www.debian.org/security/ testing/updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ testing-updates main contrib non-free
deb http://ftp.fr.debian.org/debian/ sid main contrib non-free


N'oublions pas le dépôt debport :

deb http://debian.advalem.net/debian-ports/ sid main contrib non-free


3) Réindexe les paquets :

apt-get update


4) Désormais le paquet honeyd être disponible

apt-cache policy honeyd


... et il ne reste alors qu'à l'installer :

apt-get install honeyd


Bonne chance
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015

merci pour mamiemando ta réponse ,voila le contenu de fichier /etc/apt/sources.list svp quelles sont les étapes qui je peux suivre
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021
7 124
Ah tu es en wheezy ? Oula c'est plus vieux que ce que je pensais.

Du coup deux possibilités (personnellement j'opterais pour la première qui est plus propre)

1) Soit tu migres en debian squeeze pour laquelle le paquet que tu veux est disponible. D'une part ta debian sera plus récente, et d'autre part tu pourras directement installer honeyd sans avoir à configurer tout ce que je t'ai dit. Dans ce cas tu remplaces dans ce fichier tous les wheezy par squeeze et tu mets à jour. Pas besoin de fichier
/etc/apt/preferences
puisque tu es purement en squeeze.

Personnellement je te conseille d'utiliser
aptitude
pour le faire, bien pratique pour résoudre les éventuels conflits de paquets. Plus de détails ici :
https://www.mistra.fr/tutoriels-linux-outils-debian/tutoriel-linux-apt-migration.html

Avec cette méthode tu seras donc purement en debian squeeze.

2) Soit tu adoptes la méthodologie de mon précédent message, en remplaçant :
-
testing
par
wheezy
,
- et
sid
par
squeeze
,
... dans
/etc/apt/preferences
.

Dans
/etc/apt/sources.list
:
- tu gardes ce que tu as
- tu copies toutes les lignes qui commence par le mot
deb
en fin de fichier, et dans ces lignes tu remplaces wheezy par squeeze.

Puis tu mets à jour, et tu installes honeyd.

Avec cette 2e méthode tu seras principalement en debian wheezy (comme actuellement) avec quelques paquets en squeeze (le nécessaire pour installer honeyd).

Si ce n'est pas clair, dis-moi quelle méthode tu veux suivre et copie colle le contenu de
/etc/apt/sources.list
dans ton message (plutôt que la capture d'écran) ça m'évitera d'avoir tout à réécrire :-)

Bonne chance
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015

salut,merci pour votre guide
voila la problème que je suis confronte au niveau de mise à jour
Réception de : 6 http://ftp.us.debian.org wheezy/main Translation-en [3 846 kB]
10,5 Mo réceptionnés en 5min 10s (33,9 ko/s)
W: Impossible de récupérer cdrom://[Debian GNU/Linux 7.8.0 _wheezy_ - Official i386 DVD Binary-1 20150110-13:32]/dists/wheezy/contrib/binary-i386/Packages Veuillez utiliser apt-cdrom afin de faire reconnaître ce cédérom par votre APT. apt-get update ne peut être employé pour ajouter de nouveaux cédéroms

W: Impossible de récupérer cdrom://[Debian GNU/Linux 7.8.0 _wheezy_ - Official i386 DVD Binary-1 20150110-13:32]/dists/wheezy/main/binary-i386/Packages Veuillez utiliser apt-cdrom afin de faire reconnaître ce cédérom par votre APT. apt-get update ne peut être employé pour ajouter de nouveaux cédéroms

E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
root@debian:/home/user#
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021
7 124
Dans ton fichier la 2e ligne
deb cdrom ...
doit être supprimée, ou précédées d'un
#
.
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015
>
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021

bonjour,
j'install libdnet,libevent et libpcap tous sa marche correctement mais lorsque j'installe arpd l'execution sa marche bien mais lorsque je fait make voila l'erreur qui m'affiche
root@debian:/home/sawssen/arpd# make
gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/local/include -I/usr/local/include -I/usr/local/include -I/usr/local/include -c arpd.c
arpd.c: In function `arpd_send':
arpd.c:268:34: error: expected `)' before string constant
arpd.c: In function `arpd_lookup':
arpd.c:285:34: error: expected `)' before string constant
arpd.c:294:34: error: expected `)' before string constant
arpd.c:297:34: error: expected `)' before string constant
arpd.c: In function `arpd_recv_cb':
arpd.c:426:35: error: expected `)' before string constant
make: *** [arpd.o] Erreur 1

svp aider-moi de corriger
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021
7 124
Nous sommes d'accord que ça n'a rien à voir avec le problème initial (honeyd) ?
Est-ce que ton problème avec honeyd est résolu ?
Si tu as des questions sur un autre sujet, merci d'ouvrir un nouveau fil de discussion.
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015
>
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021

non,pas encore je trouve un document contient des etapes d'installer honeyd je suivre tous ces étapes avant d'installer honeyd il y a un étape avant c'est l'installation de arpd, je fait installer arpd et faire l'execution mais je tape make il m'affichie une erreur tu peut me résoudre cet erreur
Messages postés
29899
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 juin 2021
7 124
non,pas encore je trouve un document contient des etapes d'installer honeyd je suivre tous ces étapes avant d'installer honeyd il y a un étape avant c'est l'installation de arpd, je fait installer arpd et faire l'execution mais je tape make il m'affichie une erreur tu peut me résoudre cet erreur

Pourquoi ne pas installer arpd via apt-get, comme tu es sensé(e) le faire pour tous tes logiciels autant que possible ?

Pour voir quel paquet le fournit :

apt-get install apt-file
apt-file update
apt-file search arpd | grep /arpd


Exemple :

(mando@velvet) (~) $ apt-file search arpd | grep /arpd
iproute2: /usr/sbin/arpd
iproute2: /usr/share/man/man8/arpd.8.gz
iproute2-doc: /usr/share/doc/iproute2-doc/arpd.dvi.gz
iproute2-doc: /usr/share/doc/iproute2-doc/arpd.html
iproute2-doc: /usr/share/doc/iproute2-doc/arpd.ps.gz
iproute2-doc: /usr/share/doc/iproute2-doc/arpd.txt.gz


Et donc :

apt-get install iproute2


Bonne chance
Messages postés
36
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
20 novembre 2015

merciii beacoup pour votre effort mon problème est résolue
Messages postés
2088
Date d'inscription
jeudi 16 septembre 2004
Statut
Membre
Dernière intervention
14 juin 2021
246
Salut,
La dernière version dispo dans les dépôt debian est la 1.5.7 dans oldoldstable = squeeze cf. https://packages.debian.org/search?searchon=all&keywords=honeyd

La version disponible dans les debports est pour l'architecture m68k=Motorola 68000 donc tu ne pourras pas l'installer sur ton PC.

Un programme équivalent est dans les dépôs des versions courantes : tinyhoneypot https://packages.debian.org/jessie/tinyhoneypot