Compter le nombre de valeurs selon critère

Résolu/Fermé
Kerri1012 Messages postés 33 Date d'inscription jeudi 22 octobre 2015 Statut Membre Dernière intervention 2 juin 2016 - 22 oct. 2015 à 21:06
Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 - 23 oct. 2015 à 15:40
Bonjour,
mon tableau excel ressemble à ceci :

Colonne A Colonne B
5 o
2 o
5 -
5 -
5 o
8 -
9 -
5 -

Je souhaite, dans une autre cellule, savoir combien j'ai de 5 (colonne A) qui ont des "-" dans la colonne B seulement (je devrais en avoir 3 ici).

J'ai essayer plusieurs fonctions suggérées dans d'autres posts ici mais rien ne fonctionne et je ne suis pas très dégourdi en informatique ni en excel.

Quelqu'un connait une fonction pour cela?
Merci d'avance!!

7 réponses

Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 083
22 oct. 2015 à 21:14
Bonsoir,

comme cela
=SOMMEPROD((A2:A20=5)*(B2:B20="-"))

pour le o
=SOMMEPROD((A2:A20=5)*(B2:B20="o"))
1
Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 083
22 oct. 2015 à 21:53
Re,

=SOMMEPROD((A2:A20=5)*(B2:B20="-")*(C2:C20))

si la formule est en erreur cela vient du signe $ qui doit être ajouté dans le format de la cellule. si c'est le cas dans un premier temps supprime ces $ on verra plus tard pour les insérer
1
Kerri1012 Messages postés 33 Date d'inscription jeudi 22 octobre 2015 Statut Membre Dernière intervention 2 juin 2016 7
Modifié par Kerri1012 le 22/10/2015 à 21:44
Wow Merci Mike! Cela m'aide beaucoup dans un document excel de planification financière que je tente de créer.

Maintenant que ça fonctionne, j'ai une autre question peut-être plus difficile pour faire suite.

Si je reprend mon exemple ci-haut mais que j'ajoute une autre colonne avec des prix. Je veux la somme de ces prix, seulement pour les chiffres 5 qui ont aussi un "-". Voici l'exemple :

Colonne A Colonne B Colonne C
5 o 2,09$
2 o 1,08$
5 - 0,90$
5 - 2,10$
5 o 7,96$
8 - 3,74$
9 - 1,94$
5 - 4,90$

La formule voulue me donnerait donc un total de 7,90$.

Merci d'avance!!!
0
Kerri1012 Messages postés 33 Date d'inscription jeudi 22 octobre 2015 Statut Membre Dernière intervention 2 juin 2016 7
22 oct. 2015 à 22:32
Re,

Merci beaucoup, cela fonctionne très bien sur un nouveau classeur mais pour une raison ou une autre, je n'arrive pas à le faire fonctionner dans mon fichier excel de travail. Cela me renvoi une erreur de #VALEUR! :

Le type de données d'une valeur utilisée dans la formule est incorrect.

Pourtant, même en changeant les données en nombre, ou en les laissant tous en standard, l'erreur ne me lâche pas!

Suis-je sur la bonne piste? Merci beaucoup!!
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 083
22 oct. 2015 à 22:41
Re,

as tu adapté les plages et sont elles toutes de la même longueur, même ligne de début, même ligne de fin, ensuite les données à additionner sont toutes avec des virgules et sans signe $
0
Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 083
22 oct. 2015 à 23:03
Re,
si tu veux traiter ton problème ce soir répond rapidement parce que je ne vais pas tarder à décrocher
0
Kerri1012 Messages postés 33 Date d'inscription jeudi 22 octobre 2015 Statut Membre Dernière intervention 2 juin 2016 7
23 oct. 2015 à 14:28
Ah Merci Mike!
J'ai trouver comment faire pour que ça marche sur mon document de travail.

Cela m'aide beaucoup et tu peux être certain que lorsque j'aurai d'autres formules à trouver, je vais demander ici au lieu de chercher sans trouver pendant une éternité!

Bonne journée!
0
Mike-31 Messages postés 18320 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 20 juin 2024 5 083
23 oct. 2015 à 15:40
Merci pour ton témoignage de confiance à l'égard de ce merveilleux forum Comment ça Marche et des bénévoles qui l'animent
0