Création d'un formulaire de facturation

Résolu/Fermé
Signaler
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018
-
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018
-
Bonjour à tous !
Je suis convaincu que je trouverai une aide précieuse ici, ça à déjà été le cas !

Je vous expose mon problème :

Je dois créer un fichier Excel, me permettant de recenser de manière hebdomadaire la présence d'individus sur différentes plages horaires. Chacune de ces plages horaires seront ensuite facturées à un tarif différent.
La complexité est que, selon l'heure d'arrivée, et de départ, les tarifs diffèrent...
J'aimerai pouvoir créer un fichier, qui pourra, grâce à des formules, calculer automatiquement le tarif à appliquer à l'utilisateur compte tenu de la durée de sa présence.

Voici les différents tarifs et leurs correspondances en terme de plage horaire :

Tarif 1 : arrivée 16h - départ avant 16h30
Tarif 2 : arrivée 16h - départ après 16h30 et avant 17h30
Tarif 3 : arrivée 16h - départ après 17h30
Tarif 4 : arrivée 17h30 - départ 19h.

Je suis contraint de faire apparaitre sur ce tableau Excel :
- un pointage lors de l'arrivée de l'individus, puis un lors de son départ.
- un tableau récapitulatif final regroupant les différentes présences sur les jours de la semaine.

A tous, je vous remercie par avance pour votre aide précieuse !!

1 réponse

Messages postés
13198
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 novembre 2021
2 288
Bonjour

Un exemple à adapter à tes besoins
http://www.cjoint.com/c/EJrnD5cciHl

Cdlmnt
Via
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018

En réalité, les deux données les plus importantes sont l'heure d'arrivée et l'heure de départ, sachant que je n'ai pas besoin de savoir l'heure exacte ou l'utilisateur quitte la structure, mais uniquement s'il est parti dans les différentes plages horaires (entre 16h30 et 17h30 ou après 17h30).
J'avais plutôt pensé, dans le document que j'ai envoyé tout à l'heure, à un système de pointage par croix ou puce dans ces différents créneaux, qui générerait une fois ces pointages "arrivée" et "départ" effectués, un total dans la colonne "récapitulatif".
En clair, je pointe la personne lorsqu'elle arrive, et je pointe ensuite lorsqu'elle part, ça me calcule le tarif a appliquer, sur la semaine.
Même si le temps passé est une donnée interessante, elle ne m'est pas nécessaire dans ce tableau.

Je te remercie beaucoup pour le temps que tu passes à m'aider.
Messages postés
13198
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 novembre 2021
2 288 >
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018

Re

Donc tu veux simplement comptabiliser le nombre de fois où il est parti dans chaque plage et le nombre de fois où il est arrivé à 17 h ?
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018

Re

J'ai besoin de comptabiliser :
- le nombre de fois où il est arrivé à 16h parti avant 16h30
- le nombre de fois où il est arrivé à 16h parti avant 17h30
- le nombre de fois où il est arrivé à 16h parti après 17h30
- le nombre de fois où il est arrivé à 17h30 parti à 19h00

Plus j'y réfléchi, moins je me comprend moi même ... ;-)
Messages postés
13198
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 novembre 2021
2 288 >
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018

Ok c'est plus simple s'il suffit de comptabiliser, mets dans ton tableau :
- en W4 =NB.SI.ENS($B4:$U4;"X";$B$3:$U$3;S$3)
- en X4 =NB.SI.ENS($B4:$U4;"X";$B$3:$U$3;T$3)
-en Y4 =NB.SI.ENS($B4:$U4;"X";$B$3:$U$3;U$3)
en Z4 =NB.SI.ENS($B4:$U4;"X";$B$3:$U$3;R$3)
Puis les étirer au bas des colonnes

Cdlmnt
Via
Messages postés
32
Date d'inscription
jeudi 27 décembre 2012
Statut
Membre
Dernière intervention
15 janvier 2018

Alors là, c'est top !!
Un énorme merci Via, tu me sauve !!