Recherche dans une base de donnée [Résolu/Fermé]

Signaler
Messages postés
155
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
25 mai 2020
-
Messages postés
155
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
25 mai 2020
-
Bonjour a tous

Voila, j'ai 2 col de texte A et B ,et je voudrais savoir en C si par exemple les 6 premières lettres de B1 se trouve en col. A:A, et combien de fois.

J'ai fait une formule ,mais elle ne fonctionne pas ?

Par exemple

Col. A Col. B Col. C
African queen Amenti =NB.SI(A:A;GAUCHE(B1;5)) résultat attendu 2
Agent secret
Alien agent
Ament gil
Amento

Si quelqu'un peut m'aider, merci d'avance

3 réponses

Messages postés
155
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
25 mai 2020
4
Petit correctif a ma question:
il faut lire

Voila, j'ai 2 col de texte A et B ,et je voudrais savoir en C si par exemple les 5 premières lettres de B1 se trouve en col. A:A, et combien de fois.

toutes mes excuses
Messages postés
155
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
25 mai 2020
4
Ci-joint un exemple du fichier

https://www.cjoint.com/c/EJmh42HqDjr
Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 116
Bonjour,

essaye comme cela
=SI(B1="";"";NB.SI(A:A;"*"&GAUCHE(B1;5)&"*"))


et si tu ne veux pas afficher les 0 lorsque le résultat est négatif utilise cette formule
=SI(B1="";"";TEXTE(NB.SI(A:A;"*"&GAUCHE(B1;5)&"*");"0;;;@"))


et si tu veux garder le caractère numérique du résultat sans les 0 avec une version d'Excel supérieure à 2007
=SI(B1="";"";SIERREUR(TEXTE(NB.SI(A:A;"*"&GAUCHE(B1;5)&"*");"0;;;@")*1;"")) 

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
155
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
25 mai 2020
4
Je te remercie Mike-31 ,C'est exactement ce que je cherchais.

A+ et merci