Help! Ecriture de la fonction SommeProd [Résolu/Fermé]

Signaler
-
Messages postés
25400
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
-
Bonjour,

J'aimerai ajouter un critère dans une formule utilisant la fonction SommeProd.
=SOMMEPROD((I3:I103="V")*(N3:N103<"31/10/2015"))*20 cette formule fonctionne bien pour ces critères. Je voudrais maintenant additionner les éléments répondant au premier critère mais pour des dates comprises entre le 01/11/2015 et le 30/11/2015 sur la colonne N3...N???.
Merci de votre aide.
Cordialement.


1 réponse

Messages postés
25400
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 537
Bonjour
=SOMMEPROD((I3:I103="V")*(N3:N103>="01/11/2015")(N3:N103<="30/11/2015"))
le nombre de critéres enn facteur dans SOMMEPROD n'est pas limité vous pouvez aussi écrire:
=SOMMEPROD((ANNEE(N3:N103)=2015)*(MOIS(N3:N103)=11)*(I3:I103="V"))
l'item ANNEE n'étant utile que si vos données portent sur plusieurs années

crdlmnt

Errare humanum est, perseverare diabolicum
Merci de votre réponse rapide. votre première proposition ne fonctionnant pas (Excel me propose d'ajouter le signe * entre les arguments "date" mais cela ne fonctionne pas tout de même. En revanche, en utilisant votre seconde proposition, cela fonctionne à merveille.
Cordialement
Messages postés
25400
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2020
5 537
J'ai raisonné sur le fait que votre formule fonctionnait avec la date entre guillemets, mais je ne sais pas pourquoi??
pour écrire la formule avec les dates (si elles ne sont pas en début et fin de mois)
=SOMMEPROD((I3:I103="V")*(N3:N103>=DATE(2015;11;1))*(N3:N103<=DATE(2015;11;30)))

ou alors placer les dates dans deux cellules et remplacer les codes DATE dans les items par les adresses de cellule


crdlmnt