Désactiver des liens sur un pdf [Résolu/Fermé]

Signaler
-
 Anaïs -
Bonjour,

Je viens de convertir un fichier word (que j'ai saisi) en fichier pdf et à ma grande surprise le pdf utilise des sous-titres du document pour en faire des "LIENS" conduisant vers des tiers.
En effet, si un consultant de mon pdf pointe son curseur de souris ou clique sur MES sous-titres, ça l'emmène sur d'autres sites.

Ma question : "Comment désactiver les liens qui se sont greffés sur mes sous-titres ?"


Abondance de merci à qui me dépannera.

Bien cordialement

1 réponse

Messages postés
4010
Date d'inscription
samedi 8 novembre 2014
Statut
Membre
Dernière intervention
3 octobre 2016
1 895
Bonjour Anaïs,

les liens vers des sites tiers ne pouvant pas être inventés pas Word et encore moins par le convertisseur PDF, je ne vois qu'une seule cause : le copier/coller de textes (titres) venant du Web.

Dans ton document Word, si tu appuies sur la combinaison de touches ALT F9, tu devrais voir, à la place des titres incriminés, un code comme { HYPERLINK... }. Un nouvel appui de ALT F9 réaffichera le titre.

Si c'est bien le cas et si tu veux supprimer ces liens, tu peux utiliser la combinaison de touches CTRL MAJ F9 sur chaque titre concerné.
Tu peux également, mais seulement si tu n'as pas d'autres codes de champs (table des matières, index, renvoi, etc.) sélectionner tout ton document avec CTRL A puis CTRL MAJ F9. Tu pourras ensuite reconvertir en PDF.

Si tu as de nombreux liens divers, il faudra passer par une petite macro comme celle-ci :

Sub EffaceLiens()
With ActiveDocument.Hyperlinks
For i = .Count To 1 Step -1
.Item(i).Delete
Next i
End With
End Sub

Pour la mettre en oeuvre, appuie sur ALT F11 pour accéder à la fenêtre de l'éditeur Visual Basic, menu "Insertion", "Module", copie les lignes précédentes dans la fenêtre à droite, ferme la fenêtre de l'éditeur. Depuis ton document, appuie sur ALT F8 pour accéder à la fenêtre des macros et double-clique sur "EffaceLiens".
Des variantes pullulent sur le web.

Enfin, si tu veux conserver les liens dans Word mais pas dans le PDF, lors de l'enregistrement en PDF, dans les Options, tu dois pouvoir désactiver la création des liens. Là, c'est selon la version de Word et le convertisseur que tu utilises.

C-Claire
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonsoir C-Claire,

Un immense MERCI pour ton aide très qualifiée, très PRO.
Mon pb est guéri.

Moi qui maîtrise si peu l'informatique, je suis bouche bée devant ces docteurs que vous êtes sur les forums pour nous venir en aide avec bienveillance.
Je tire mon chapeau avec profond respect & reconnaissance..