Fonction Sur Excel 2010 pour détecter le manquant de 3 Cellules [Résolu/Fermé]

Signaler
Messages postés
32
Date d'inscription
vendredi 31 juillet 2015
Statut
Membre
Dernière intervention
16 septembre 2018
-
Messages postés
32
Date d'inscription
vendredi 31 juillet 2015
Statut
Membre
Dernière intervention
16 septembre 2018
-
Bonjour tout le monde,

Merci de bien vouloir m'aider pour trouver la solution à mon problème.
Je suis sur Excel 2010.
j'ai 3 Cellules qui contiennent des textes: Par exemple A1="a" , A2="b" et A3="c".
Je cherche la formule à mettre dans la cellule A4 pour donner le text "c" si A3 est vide, ou le text "a" si A1 est vide.... etc . c'est-à-dire détecter le texte qui manque des 3 ( "a", "b" et "c").
J'ai essayé la fonction Si(OU(..... mais c'est un peu compliqué
Merci infiniment


5 réponses

Messages postés
3165
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
16 avril 2021
440
Bonjour,

=si(estvide(a1);"a";si(estvide(a2);"b";si(estvide(a3);"c";"")))

A condition qu'il ne manque qu'une information !
Messages postés
9709
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 avril 2021
2 085
Bonjour

Si j'ai bien compris
=SI(A1="";"a";SI(A2="";"b";SI(A3="";"c";"pas de vide")))

Cdlmnt
Messages postés
32
Date d'inscription
vendredi 31 juillet 2015
Statut
Membre
Dernière intervention
16 septembre 2018

merci pour votre aide.

les textes: "a", "b" et "c" peuvent s'alterner, c'est à dire on peut trouver "a" soit dans la cellule A1 soit dans A2 soit dans A3, et même chose pour "b" et "c".
je cherche la formule qui détecte le texte manquant peu importe l'emplacement de ces textes dans les 3 cellules.
Merci encore.
Messages postés
9709
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
16 avril 2021
2 085
Toujours pas très clair.
Une tentative quand même
http://www.cjoint.com/c/EHbm7zsXS2u

Si ça ne correspond pas, peux tu envoyer la partie concernée de ton fichier, au format excel 2003, sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu

Cdlmnt
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
838
Bonjour à tous,

Une idée :
=SUBSTITUE(SUBSTITUE(SUBSTITUE("ABC";MAJUSCULE(A1);"");MAJUSCULE(A2);"");MAJUSCULE(A3);"")

Cordialement
Messages postés
32
Date d'inscription
vendredi 31 juillet 2015
Statut
Membre
Dernière intervention
16 septembre 2018

Merci c'est ce que je voulais
merci pour votre collaboration