Elements non-chiffrés sur sites web [Résolu/Fermé]

Signaler
-
 Olive -
Bonjour,
Sur certains sites où se trouvent des pages sécurisées ( pages de connexion, de paiements ), j'ai l'adresse en https, mais je n'ai pas le cadenas vert.
Ou pour être exact, au moment où la page se charge le cadenas vert est présent; puis une fois que la page est complètement chargé, il est remplacé par un point d'exclamation dans un triangle. Celui-ci m'indique que la page " n'est pas complètement sécurisée car elle contient certains éléments non-chiffrés. "

Les sites sur lesquels cela se produit sont des sites connus et sur lesquels j'ai l'habitude de me connecter ou de passer des commandes sans avoir jamais eu ce genre de problème.
Cela n'arrive pas sur tous les sites.
il y a certainement sur ces pages un élément commun qui n'est pas chiffré, mais comment l'identifier ?

Pouvez-vous m'aider à résoudre ce problème ?
Par avance merci !


2 réponses

Messages postés
180215
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
24 novembre 2020
22 678
Salut,

Non on ne peut pas, ça vient du site qui mélange du contenu sécurité (HTTPs) et du contenu non sécurisé (HTTP).
Le navigateur t'en informe en émetant un avertissement car dans la logique, si tu fais du HTTPs, tu fais tout et pas la moitié, surtout que tu ne sauras pas, à moins de connaître quel contenu ne l'est pas.

En gros, ça peut arriver si, par exemple, quand c'est mal branlé, style la page importante, comme un login (là où tu mets ton user et mot de passe) est en HTTPs avec du contenu externe HTTP (typiquemet une régie de pub qui n'est pas en HTTPs ou un cdn).

c'est typiquement le cas chez moi : https://forum.malekal.com

Tu as un exemple de site pour vérifier ?

Like the angel you are, you laugh creating a lightness in my chest,
Your eyes they penetrate me,
(Your answer's always 'maybe')
That's when I got up and left
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Le dernier site où j'ai remarqué cela est cultura.com.
Le lien "s'identifier" en haut à droite, ainsi que la page de paiement si vous êtes inscrit sur ce site.
Merci pour votre aide.
Messages postés
180215
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
24 novembre 2020
22 678
ils ont laissé des images en HTTP, ça semble être des erreurs d'étourderies.


Sur la page d'index, y a aussi du contenu externe en HTTP : hxxp://js.sddan.com/GS.d?pa=20761&target=1&u=https://www.cultura.com/&r=

Du coup, pas full HTTPs, du coup, Firefox émet un avertissement.
Ca semble que Google Chrome et Internet Explorer ne disent rien.




Merci pour votre réponse et vos explications.
Du coup, il n'y a pas vraiment de risque à se connecter ou effectuer des paiements sur ces pages, tant que ce ne sont que des "images" ou des contenus externes qui sont en http et non les zones de formulaires. Non ?

Et effectivement, votre forum, m'apparait comme n'étant pas totalement sécurisé.
Messages postés
180215
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
24 novembre 2020
22 678
Non aucun.