Liste déroulante sous condition

[Fermé]
Signaler
-
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
-
Bonjour,


Sur excel 2013 je veux faire un classeur pour des validations de travaux

Une première liste déroulante pour "hydraulique"-> choix oui ou non

Si hydraulique= oui je veux une liste déroulante CHOIX dans pour schéma hydraulique avec "non réalisé" ou "réalisé" ou "!"

Si hydraulique= non alors je veux une valeur en l'occurrence NA

J'y parviens presque avec

SI(HYDRAULIQUE="OUI";CHOIX;"NA")

Seulement si je rentre non, j'ai un blanc dans la cellule et si je clique sur cette cellule j'ai une liste déroulante avec un seul choix NA (c'est normal) mais je voudrais que NA s'affiche directement.

Merci d'avance
Damien

2 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
536
Bonjour,

Une solution en utilisant une procédure évènementielle
https://www.cjoint.com/c/EGlgM73scDb

A+
Messages postés
33
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2020

Bonjour,
J'ai moi aussi une question de ce type, et je voudrais savoir s'il y a une solution possible sans passer par une macro.

Dans la cellule L8, je souhaite afficher :
- une liste déroulante si E3 est vide
- du texte prédéfini si E3 est remplie

Merci d'avance si quelqu'un a la solution !
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
56
Bonjour,

Ma liste : I1:I7
M1 : texte à afficher

Formule à mettre dans source (validation de données et à adapter) :

=SI(E3="";$I$1:$I$7;$M$1)

Cordialement,
Excel-Worker
Messages postés
33
Date d'inscription
mardi 4 novembre 2014
Statut
Membre
Dernière intervention
14 avril 2020

Est-ce que je dois mettre la formule dans la case ou dans Validation de données ?
J'ai essayé en la mettant dans Validation de données (en sélectionnant Liste) : =SI(E3="";catégorie;BdD!$B$37)

Mais j'ai encore une liste lorsque E3 est remplie (avec le texte souhaité). Je voudrais que le texte s'affiche directement (sans liste) dans la case, comment puis-je faire ?

Merci de votre aide
Alice
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
56
Je suis en train de te chercher une solution mais si quelqu'un a une idée au passage, il la postera.

Cordialement,
Excel-Worker