Multiplier deux colonnes [Résolu/Fermé]

Signaler
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
-
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
-
Bonjour,

Je suis sur Excel 2010 et je voudrais savoir comment multiplier automatiquement les cases de deux colonnes ligne à ligne sans avoir à multiplier case par case à chaque fois.
Dit plus clairement il s'agit de mettre dans la case Cn le résultat An*Bn (la ligne n variant soit en nombre fini soit indéfiniment).
La colonne A représente le prix d'un article et la colonne B le nombre d'articles.Donc la colonne C est censée indiquée le prix total pour chaque article.
Et accessoirement y a-t-il un moyen d'afficher le cumul à chaque ligne?

Merci d'avance.

2 réponses

Messages postés
23485
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
6 350
Bonjour,

en 1 fois :
=SOMMEPROD(A2:A15;B2:B15)

Ou cumul, en C2:
=SOMME(A2*B2;C1)

à tirer vers le bas en double-cliquant la poignée de recopie.
eric


En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
9
Ok ça m'en apprend plus. Et si je veux que dans chaque case de la colonne C il y ait le produit des cases de A par B à chaque ligne sans faire le cumul ?
OK je viens de découvrir qu'en tirant la poignée ça généralisait le calcul.
Merci beaucoup.
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
14 074 >
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020

Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
9
Ok merci à vous.
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
14 074
"comment multiplier automatiquement les cases de deux colonnes ligne à ligne sans avoir à multiplier case par case à chaque fois"
Tu ne crois pas que c'est une question un peu tirée par les cheveux ?
Ou alors je n'ai pas compris ton problème ...
  • D'habitude, les utilisateurs d'Excel écrivent en C2 la formule =A2*B2 et la recopient vers le bas avec l'une des 4 ou 5 méthodes disponibles ....... Cela te pose problème ?
  • Pour le cumul, je mets en D2 la formule =C2 ..................................... puis en D3 je mets la formule =D2+C3 que je recopie vers le bas.
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
9
Comment faire pour ne pas avoir à taper A2*B2 puis A3*B3 jusqu'à A20*B20 ?
Y a pas une formule qui permet de le faire une seule fois automatiquement ?
Quelles sont ces "méthodes disponibles" ?

Merci d'avance.
Messages postés
52285
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 septembre 2020
14 074 >
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020

Méth 1A = Clic sur icône Copier - Sélectionner cellules du bas - Clic sur icône Coller
Méth 1B = Idem avec raccourcis clavier ctrl+C / ctrl+V
Méth 1C = Idem avec clic droit et sélection des outils dans la liste déroulante
Méth 2A = Tirer la poignée (en bas à droite) de la cellule vers le bas
Méth 2B = Double-clic sur la poignée (solkution d'Eric)
Méth 3 = Sélectionner la formule et les cellules suivantes, et faire ctrl+B
Messages postés
241
Date d'inscription
lundi 1 mars 2010
Statut
Membre
Dernière intervention
20 août 2020
9
Ok merci beaucoup.