Formule excel pour trouver un libellé correspondant à un code

Fermé
Youbert
Messages postés
8
Date d'inscription
lundi 26 octobre 2015
Statut
Membre
Dernière intervention
27 octobre 2015
- 26 oct. 2015 à 17:51
Raymond PENTIER
Messages postés
56088
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2022
- 20 nov. 2015 à 04:29
Bonjour,
Dans un onglet excel j'ai une liste de code (colonne A) correspondant à des noms colonne B.
Dans un autre onglet, j'ai les mêmes codes en colonne A et des colonnes C, D, E.... avec d'autres donnée. La colonne B est vide et j'aimerais saisir une formule pour que les libellés correspondant aux codes apparaissent sur cette colonne.
Exemple
Onglet 1 colonne A : 75 / colonne B : PARIS.
Onglet 2 colonne A : 75 / colonne B est vide.
J'aimerais connaitre la formule pour que PARIS apparaisse sur la colonne B de l'onglet 2.
Merci
A voir également:

4 réponses

Raymond PENTIER
Messages postés
56088
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2022
17 210
26 oct. 2015 à 20:57
Salut.

Je viens de regarder ton fichier. Questions prélables :
  • à quoi servent les commentaires (identiques au contenu de la cellule) en première ligne de chaque feuille ?
  • pourquoi n'as-tu pas essayé d'écrire la formule, à partir des deux tutos dont je t'ai envoyé le lien, et de la formule dont je t'ai indiqué la syntaxe ? J'aurais préféré rectifier une formule erronée plutôt que de tout faire à ta place ...
20
Raymond PENTIER
Messages postés
56088
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
19 mai 2022
17 210
Modifié par Raymond PENTIER le 26/10/2015 à 21:30
De plus, ma formule marche du premier coup, sans aucun changement, pour la première cellule B2 !
Simplement, pour qu'après la recopie vers le bas la plage ne soit pas modifiée, il faut juste prendre la précaution de remplacer A2:B99 par A$2:B$51.

Et si tu avais défini le nom "matrice" pour la plage Feuil1!A2:B51, la formule dans toute la colonne Feuil2!B:B aurait été =RECHERCHEV(A:A;matrice;2;0)
https://www.cjoint.com/c/EJAuDTEUacz
Je t'incite à lire, comprendre et appliquer les deux tutos de mon post #1
0