Calculer total heures avec du textes dans certain cellules

Résolu/Fermé
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016
-
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016
-
Bonjour,
voila j'ai un tableau qui doit me compter les heures; mais dans ça colonne il y a du texte
ma formule est SOMMEPROD((ESTNUM(CHERCHE("08:00";H6:H36))*(H6:H36="08:00")))*"08:00"+SOMMEPROD((ESTNUM(CHERCHE("08:19";H6:H36))*(H6:H36="08:19")))*"08:19"+SOMMEPROD((ESTNUM(CHERCHE("08:49";H6:H36))*(H6:H36="08:49")))*"08:49"+SOMMEPROD((ESTNUM(CHERCHE("07:00";H6:H36))*(H6:H36="07:00")))*"07:00"+SOMMEPROD((ESTNUM(CHERCHE("06:00";H6:H36))*(H6:H36="06:00")))*"06:00"+H25+H24
mais cela ne marche pas
si quelqu'un a une solution je prend je n'arrive pas a trouver
comment joindre un exemple
je vous remercie par avance
OCTOBRE
jeudi 1 08:00
vendredi 2 08:19
samedi 3 we
dimanche 4 we
lundi 5 08:19
mardi 6 08:19
mercredi 7 08:49
jeudi 8 08:00
vendredi 9 08:19
samedi 10 we
dimanche 11 we
lundi 12 08:19
mardi 13 08:19
mercredi 14 08:49
jeudi 15 08:00
vendredi 16 08:19
samedi 17 we
dimanche 18 we
lundi 19 06:00
mardi 20 06:00
mercredi 21 RTT
jeudi 22 RTT
vendredi 23 RTT
samedi 24 we
dimanche 25 we
lundi 26 RTT
mardi 27 RTT
mercredi 28 RTT
jeudi 29 RTT
vendredi 30 RTT
samedi 31 we
total 99:51 doit faire:111:51




4 réponses

Messages postés
13353
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 janvier 2022
2 330
Bonjour

Plus simple :
Si les jours avec les heures sont en colonne H et commencent en H2, créer la colonne I avec en I2 la formule pour extraire l'heure :
=SIERREUR(TEMPSVAL(DROITE(H2;5));"")
Etirer la formule au bas de la colonne

Faire ensuite dans la cellule de ton choix la somme des valeurs de la colonne I
Mettre cette cellule en Format personnalisé [h]:mm pour autoriser le dépassement de 24 h

Cdlmnt
Via

Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016

bonjour Via
merci de ta réponse mais je ne peut pas car la colonne H les cellules calcul le jour en F exemple jeudi me donne 08:00 avec une fonction que j'ai bricolé
je ne sais pas comment faire pour envoyer un fichier exemple
merci
Messages postés
17829
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 janvier 2022
4 910
Bonsoir,

pour joindre ton fichier anonymisé sert toi de ce lien
https://www.cjoint.com/
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016

bonsoir Mike-31
je joins un exemple du fichier
merci
https://www.cjoint.com/c/EFrqxkb4eXE
Messages postés
13353
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
27 janvier 2022
2 330 >
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016

Re,

Le calcul adéquat : http://www.cjoint.com/c/EFrrgo5COTj

Cdlmnt
Via
Messages postés
17829
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 janvier 2022
4 910
Re,

dans ta proposition initiale tes données se présentaient sous ce format
jeudi 1 08:00
vendredi 2 08:19
samedi 3 we etc ...
dans ce cas pour ta plage H6:H36 la formule matricielle pour un calcul direct
est
=SOMME(SIERREUR(DROITE(H6:H36;5)*1;0))

valider la formule en cliquant en même temps sur les 3 touches Ctrl, Shift et Entrée, si tu fais bien la formule se placera entre ces accolades {}

dans ton fichier joint les données sont ordonnées mais la formule colonne C renvoi des valeurs format texte, remplace la formule en C2 et incrémente la vers le bas
= SI(JOURSEM(A2)=1;"we";SI(JOURSEM(A2)=2;"08:19"*1;SI(JOURSEM(A2)=3;"08:19"*1; SI(JOURSEM(A2)=4;"08:49"*1; SI(JOURSEM(A2)=5;"08:00"*1; SI(JOURSEM(A2)=6;"08:19"*1; SI(JOURSEM(A2)=7;"we";)))))))


ensuite faire la somme
=SOMME(C2:C32)
et formater la cellule [hh]:mm
par contre lorsque tu modifies les heures ou tu saisis du texte comme RTT en colonne C, la formule est effacée il faudra la reconstituer
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
17829
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 janvier 2022
4 910
En attendant le retour de tuileries

https://www.cjoint.com/c/EFrvuCeFYRj
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016

Bonjour Mike-31
Je te remercie cela marche bien.
je vais abuser peut être, voila sur la colonne C il y a des cellule en jaune avec une heure "06:00" que j'inscris.je voudrais que cela ce fasse avec une donnée, que je mes a jour chaque année incorporé a toute les cellules.
merci encore
Messages postés
17829
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
24 janvier 2022
4 910
Re,

il n'y a aucun problème pour ajouter des critères à la formule mais comment trouver l'argument pour signaler à Excel que certain lundis ou mardis doivent afficher 8:19 ou 6:00 ou encore RTT
la solution la plus logique serait d'ajouter une colonne dans laquelle tu saisirais ces critères particuliers et serait pris en priorité dans la formule en colonne C
https://www.cjoint.com/c/EFshlauf5rj

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
16
Date d'inscription
mercredi 3 décembre 2003
Statut
Membre
Dernière intervention
7 juin 2016

bonsoir Mike-31,
je te remercie encore. j'ai inséré une colonne et j'ai saisi mes critères ,et ça
marche
donc problème résolu
bonne soirée