Validation de données formule [Résolu/Fermé]

Signaler
-
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
-
Bonjour à tous,

J'aurais besoin d'aide sur excel.
En effet, j'ai un tableau de données pour des commandes de tickets. Les utilisateurs donnent le nombre de tickets qu'ils souhaitent. Un certain montant est subventionné et un autre est à leur charge. La subvention ne peut pas dépasser, au total, un certain montant.

Dans ma colonne H j'ai le nombre de ticket qu'ils peuvent prendre. Sachant qu'il y a plusieurs catégories donc plusieurs lignes.
Dans ma colonne I j'ai le montant de la subvention selon le nombre de tickets pris.
Dans ma cellule I32 j'ai le montant de la subvention à ne pas dépasser.

Pour le moment, j'ai sélectionné la colonne H en faisant validation de données -> personnalisée -> =somme(i3:i30)>I32 et un message d'erreur d'arrêt.

Le problème est que dès la première saisie du nombre de ticket, le message apparait alors que le montant n'est pas du tout dépassé.
Je ne comprends pas quel est le souci et c'est pourquoi je viens à vous !

Je vous remercie d'avance pour votre aide.

Marion

1 réponse

Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633
Bonjour
.. Erreur classique dans ce type de validation, la formule doit être ce que vous autorisez, pas ce que vous interdisez:
=SOMME($I$3:$I$30)<=I32
Par ailleurs, bloquez bien le champ avec les signes $ sinon il se cale sur la cellule sélectionnée
crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
1
Date d'inscription
mardi 2 juin 2015
Statut
Membre
Dernière intervention
2 juin 2015

Bonjour,
Merci beaucoup pour votre aide. En effet, cela parait logique étant donné le message.
Le document marche parfaitement !
Merci encore.
Messages postés
25638
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 633
Pas de quoi
je passe le sujet en résolu
Bonne route
crdlmnt