Supprimer #N/A

Résolu/Fermé
Signaler
-
 mic6259 -
Bonjour,

J'ai la formule =RANG(B2;$B$2:$B$100;0)

Comment enlever les #N/A dans la colonne C quand les cellules de la colonne B sont vide

Merci


A voir également:

3 réponses

Messages postés
1
Date d'inscription
dimanche 31 mai 2015
Statut
Membre
Dernière intervention
31 mai 2015
2
Bonjour,

je ne sais pas si c'est valable pour ta version d'excel mais j'ai l'habitude d'utiliser =SI(ESTNA(ici mettre ta formule);0;(ici mettre ta formule))


en valeur "si vrai" tu peux mettre soit 0 soit : " "

c'est comme tu veux

soit =SI(ESTNA(RANG(B2;$B$2:$B$100;0));0;(RANG(B2;$B$2:$B$100;0)))

ou

=SI(ESTNA(RANG(B2;$B$2:$B$100;0));" ";(RANG(B2;$B$2:$B$100;0)))

Aurore
3
Messages postés
26403
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 janvier 2022
6 184
Bonjour
Depuis Excel2007, on dispose d'un code passe partout qui permet d'éliminer l'affichage d'erreur quelles que soient les conditions:
=SIERREUR(formule);"")
e dans votre cas:

=SIERREUR(RANGE(B2;$B$2:$B$100);"")
1
Bonsoir
La meilleure solution est la votre
Merci beaucoup à tous
0
Messages postés
5800
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
18 janvier 2022
685
Bonjour

Essayer ceci

=SI(B2="";"";RANG(B2;$B$2:$B$100;0))
0