Moyenne Générale sans une matière

Fermé
corentinus69 Messages postés 16 Date d'inscription vendredi 9 mars 2012 Statut Membre Dernière intervention 17 mai 2015 - 17 mai 2015 à 23:16
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 mars 2023 - 18 mai 2015 à 00:39
Bonjour,

Après avoir réalisé un tableur excel pour rentrer mes notes scolaires un problème se fait voir...
J'ai attribué à chaque matière une moyenne avant de faire l'ensemble de ces dernières en une moyenne générale. Mais si une matière n'a pas de note (exemple le sport) alors la moyenne générale ne peut pas se calculer.
Que faire ?
J'ai pensé qu'il était possible de faire "marcher" la formule que si des notes étaient rentrées dans les cellules mais je n'ai pas trouvé..

Merci d'avance !

1 réponse

Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 mars 2023 1 778
17 mai 2015 à 23:22
Bonjour,

Pour chaque matière utilses une formule du type :
=SI(NB(B2:F2)>0;MOYENNE(B2:F2);"")
corentinus69 Messages postés 16 Date d'inscription vendredi 9 mars 2012 Statut Membre Dernière intervention 17 mai 2015 1
17 mai 2015 à 23:58
Comment y entrer les coefficients de chaque note dans une matière ?
0
Patrice33740 Messages postés 8556 Date d'inscription dimanche 13 juin 2010 Statut Membre Dernière intervention 2 mars 2023 1 778
18 mai 2015 à 00:39
Un coefficient par note !!!!!!!!!!!!
ou un coefficient par matière ???

Par matière avec le coeff. en G2 :
=SI(NB(B2:F2)>0;MOYENNE(B2:F2)*G2;"")

Pour la moyenne générale : Somme(des moyennes par matière) / somme(des coefficients)
0