Extraire des données communes à partir de deux colonnes excel

Fermé
0548 Messages postés 73 Date d'inscription samedi 21 mars 2015 Statut Membre Dernière intervention 19 janvier 2017 - 1 mai 2015 à 20:23
Frenchie83 Messages postés 2237 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 20 juin 2022 - 3 mai 2015 à 18:20
Bonjour,
j'aimerai savoir quel est la fonction en excel 2013 qui permet d'extraire les chaines de caractères communes (des titres dans mon cas ) entre la colonne A et la colonne B issue de la même feuille .
Merci d'avance.



A voir également:

5 réponses

Whismeril Messages postés 18004 Date d'inscription mardi 11 mars 2003 Statut Contributeur Dernière intervention 27 novembre 2022 873
1 mai 2015 à 21:02
Bonsoir tu veux faire ça en formule ou en macro?
Dans les 2 cas tu n'es pas dans le bon forum, c'est juste pour déplacer dans le bon.
0
0548 Messages postés 73 Date d'inscription samedi 21 mars 2015 Statut Membre Dernière intervention 19 janvier 2017
2 mai 2015 à 00:18
je veux faire ça en formule ; si vous ne m'avez pas bien compris , j'aimerai comparer deux colonnes et afficher le résultat des valeurs communes dans une troisième colonne .
0
Frenchie83 Messages postés 2237 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 20 juin 2022 333
3 mai 2015 à 10:10
Bonjour
Une proposition assez simpliste
https://www.cjoint.com/c/EEdkrpQ2C7o
Ceci extrait les valeurs présentent dans les 2 colonnes, puis faire un tri par ordre descendant sur la colonne C pour avoir les résultats sans les vides. On doit pouvoir faire les 2 actions en 1 seule formule, je cherche.
Cdlt
0
PHILOU10120 Messages postés 6170 Date d'inscription lundi 16 avril 2012 Statut Contributeur Dernière intervention 24 novembre 2022 744
3 mai 2015 à 13:04
Bonjour

Si les colonnes à comparer sont A et B dans l'exemple j'ai mis 40 lignes

=SI(NB.SI($A$1:$A$40;B1)>0;B1;"")
0
michel_m Messages postés 16582 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 27 novembre 2022 3 283
3 mai 2015 à 15:05
Bonjour tout ce beau monde,

une méthode comme une autre (on pourrait peut-^tre utiliser une matricielle mais mon poil dans la main m'interdit la prise de t^te le dimanche)

https://www.cjoint.com/?3Edprr0Dnuz
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Frenchie83 Messages postés 2237 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 20 juin 2022 333
3 mai 2015 à 18:20
Re-bonjour à tous
Autre méthode avec calculs intermédiaires
https://www.cjoint.com/c/EEdst6tJUk2
(Si plusieurs données sont identiques dans l'une ou l'autre des colonnes, elles ne seront extraites qu'une seule fois, ce que ne faisait ma première solution).

Si vous voulez vous passer des colonnes D et E, vous pouvez toujours faire un tri par ordre descendant sur la colonne C pour avoir les résultats sans les vides

Pour l'instant, pas encore trouvé la formule unique qui extraira les doublons et les assemblera sans laisser d'espaces vides, mais je pense que c'est faisable.
Cdlt
0