Excel : si case vide pas de formule [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
25 avril 2015
-
Messages postés
2
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
25 avril 2015
-
Bonjour,

Étant complètement novice sur Excel je me permet de poser cette question.

J'ai un fichier excel dans lequel j'entre des données brutes dans les premières colonnes et lignes. S'en suit une série de calculs à partir de ces données brutes puis d'autres calculs découlant des premiers calculs etc.

Or Un calcul prend en compte la moyenne de la première case et même si je n'ai pas entré de données dans certaines cases le calcul se fait ce qui me fausse entièrement mes résultats..

Exsite-t-il une formule pouvant dire à Excel "si cette ou ces cases sont vides alors il ne faut pas faire le calcul (ou ne rien afficher) par la suite" ?

Peut être que cette réponse a déjà été posée mais je n'ai pas trouvé et/ou pas compris.

Merci d'avance pour votre aide

Alexandre



A voir également:

2 réponses

Messages postés
2
Date d'inscription
samedi 25 avril 2015
Statut
Membre
Dernière intervention
25 avril 2015
1
Je viens juste de trouver grâce à un ami s'y connaissant.

Pour celles et ceux qui chercheraient il suffit de mettre dans la case de la formule (avec exemple) :
=SI(A1="";"";B1-A1)

A1 correspond à la case où sont les données, B1 également.

Pour expliquer la formule : Si la case A1 est vide (A1="") alors elle sera vide (;"") mais si elle ne l'est pas alors la formule sera B1-A1 (;B1-A1)

J'espère que ça en aidera en tout cas
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
4148
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 397
Bonjour

Un exemple de ton tableau serait le bienvenu.
https://www.cjoint.com/
Cordialement