Formule multiple sur une case

Résolu/Fermé
didier28 - 4 avril 2015 à 16:06
Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 - 4 avril 2015 à 16:42
Bonjour,
voici la formule que je viens de taper, mais qui ne fonctionne pas
=SI(((T34-R34)=3)ET SI(T34=$R$1)=;1;"")
pouvez vous m'aider à trouver la bonne formule ???

par avance merci de vos réponses

cordialement
Didier

4 réponses

Adri1infos Messages postés 623 Date d'inscription mardi 31 mars 2015 Statut Membre Dernière intervention 27 février 2020 297
Modifié par Adri1infos le 4/04/2015 à 16:21
Bonjour,
On ne peut pas mettre de "ET" dans une formule, ou alors sa fonctionne très mal. Le mieux est d'écrire ceci (dans la même case) :
=SI((T34-R34)=3;"1";SI(T34=$R$1);"1";""))

En gros :
- Si T34-R34 = 3 la case affiche "1" (tu peut modifier)
et - Si T34=R1 la case affiche aussi "1" (tu peut modifier)

Sinon, cela n'affiche rien (;"")
0
merci pour votre réponse
cordialement didier
0
merci de votre réponse
cordialement didier
0
merci de votre réponse
cordialement
didier
0
via55 Messages postés 13886 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 30 septembre 2022 2 490
4 avril 2015 à 16:23
Bonjour didier28
Essaie plutôt :
=SI(ET(T34-R34=3;T34=$R$1);1;"")

Cdlmnt
Via
0
ozone_ Messages postés 1478 Date d'inscription lundi 13 juillet 2009 Statut Membre Dernière intervention 27 septembre 2022 507
Modifié par ozone_ le 4/04/2015 à 16:26
Pourquoi ne peut on pas mettre de ET dans la formule ?!

=SI(ET((T34-R34)=3;(T34=$R$1));1;"c'est faux !")


1f u c4n r34d th1s u r34lly n33d t0 g37 l41d !
0
Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 4 996
Modifié par Mike-31 le 4/04/2015 à 16:46
Bonjour,

ta formule ne veut rien dire, pas plus d'ailleurs que ma proposition
=SI(ET((T34-R34)=3;(T34=$R$1)=1);"")
ou comme cela
=SI(ET(T34-R34=3;T34=$R$1);1;"")

explique simplement ce que tu veux faire
si T34-R34 = 3 ça c'est bon
mais la que veux tu faire ET SI(T34=$R$1)=

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0