Supprimer un caractère au début du texte "excel 2013" [Résolu/Fermé]

Signaler
-
 jacob -
Bonjour tout le monde,
je voudrais supprimer d'une colonne des points virgules qui se placent au début de quelques lignes.Mon fichier est comme suit :
Marché du bois
;Marché des voitures
;marché des ...
Marché des ..
.
..
...

Merci d'apporter votre aide :)



A voir également:

1 réponse

Messages postés
17111
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
27 avril 2021
10 348
Bonjour,

S'il n'y a pas de points-virgules ailleurs qui sont utiles à quelque chose, tu peux simplement utiliser un Recherche-Remplace (Ctrl + h) :
Rechercher : ;
Remplacer par : tu laisse vide

m@rina
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
17111
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
27 avril 2021
10 348
Alors, il faut une formule :

=SI(GAUCHE(A1;1)=";";REMPLACER(A1;1;1;"");A1)

Tu recopies la formule sur toute la colonne, puis tu la copies-colles en valeur pour ne récupérer que le texte.

m@rina
C parfait! merci bcp Marina ;)
Svp comment est ce que je peux inverser cette fonction c'est à dire supprimer des points virgules qui se placent à la fin de la ligne?
=SI(DROITE(A1;1)=";";REMPLACER(A1;1;1;"");A1)
j'ai essayé avec cette fonction mais ça efface le premier caractère du côté gauche
Merci encore une fois
Messages postés
17111
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
27 avril 2021
10 348
Bonjour,

Effectivement, ça ne va pas fonctionner comme ça.
Essaie plutôt ceci :

=SI(DROITE(A1;1)=";";STXT(A1;1;(NBCAR(A1)-1));A1)

m@rina
Parfait! Merci infiniment marina :)