Fonction SI imbriquée (plusieurs critères et conditions)

[Fermé]
Signaler
-
Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
-
Bonjour,

Je suis désolé par avance si la question a déjà été posée mais je cherche à faire une fonction SI imbriquée avec plusieurs critères et conditions (pas certains que ce soit très précis).

ex :

COL A;COL B;COL C
Bronze;1;résultat dépendant de A & B
Silver;1;résultat dépendant de A & B
Gold;1;résultat dépendant de A & B


En COL C je cherche à trouver la formule qui aura comme critères :
- SI COL A = BRONZE ET COL B = 1 Alors COL C = 3
- SI COL A = BRONZE ET COL B compris entre 2 & 3 Alors COL C = 2
- SI COL A = SILVER et COL B = 1 Alors COL = 3

Ainsi de suite.

Je souhaite donc "catégoriser" la Colonne selon 2 critères (COL A et COL B).

Merci d'avance pour votre réponse.

2 réponses

Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
4 670
Bonjour,

Comme cela

=SI(ET(A2="BRONZE";B2>=2;B2<=3);2;SI(ET(A2="BRONZE";B2=1);3;SI(ET(A2="SILVER";B2=1);3;"")))

ou en plus court

=SI(ET(OU(A2="BRONZE";A2="SILVER");B2=1);3;SI(ET(A2="BRONZE";B2>=2;B2<=3);2;""))

Merci beaucoup pour la réponse Mike-31.

Pour la méthode plus courte, j'ai peur que ça ne fonctionne pas car la Colonne C va changer.
J'ai aussi tenté une rechercheV en passant par plusieurs étapes mais ça demande plus d'étapes :).
Messages postés
17419
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
29 juillet 2021
4 670
Re,

La première formule te permet d'ajouter facilement d'autres conditions

ou tu passes par une colonne intermédiaire ou tu concaténes les données A et B et si cette colonne tu la positionnes en colonne A tu fais une RECHERCHESV