Recherche en fonction de deux critères [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 18 février 2015
Statut
Membre
Dernière intervention
23 février 2015
-
Messages postés
3
Date d'inscription
mercredi 18 février 2015
Statut
Membre
Dernière intervention
23 février 2015
-
Bonjour,

J'ai un tableau excel avec 3 colonnes comme ci-dessous :
date heure nombre
Je souhaite, en fonction de la date et de l'heure de la journée, trouver le nombre associé. J'ai bien essayé avec INDEX et EQUIV mais cela ne fonctionne pas avec les dates et les heures. J'ai bien défini le format des cellules date pour les dates et heure pour les heures.
Il m'affiche l'erreur #N/A.
Quelqu'un pourrait-il m'aider?

P.S. j'ai fais le test avec une liste bidon du style
lettre chiffre couleur
et cela fonctionne donc c'est bien le format des cellules qui semble poser problème.

D'avance, merci!

1 réponse

Messages postés
1146
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
28 octobre 2020
89
Bonjour,

Essaye la fonction sommeprod ?
Messages postés
3
Date d'inscription
mercredi 18 février 2015
Statut
Membre
Dernière intervention
23 février 2015

Bonjour eljojo_e,

en supposant date dans la colonne A, heure dans la colonne B, nombre dans la colonne C, la date recherchée dans la case D1 et l'heure recherchée dans la colonne E1,
j'ai rentré la formule suivante :
=SOMMEPROD(((A2:A10)=D1)*((B2:B10)=E1))
et cela me retourne la valeur 0 alors que dans mon tableau il y a 12 998.
une petite idée ?
Messages postés
1146
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
28 octobre 2020
89 >
Messages postés
3
Date d'inscription
mercredi 18 février 2015
Statut
Membre
Dernière intervention
23 février 2015

SOMMEPROD(((A2:A6)=D1)*((B2:B6)=E1)*C2:C6)

il manquait la fin ;)

Le dernier "argument" fait la somme des nombre dont les premier arguments sont vrai.
Messages postés
3
Date d'inscription
mercredi 18 février 2015
Statut
Membre
Dernière intervention
23 février 2015

Merci beaucoup!
Finalement, cela fonctionne également avec INDEX et EQUIV.