Mysql : récupérer ses sites

Résolu/Fermé
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 - Modifié par dindoun le 30/01/2015 à 20:57
mamiemando Messages postés 32067 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 27 janvier 2023 - 8 févr. 2015 à 01:03
salut
j'ai du faire une nouvelle installation
j'ai gardé les répertoires /var/www et /var/lib/mysql

comment puis-je sur la nouvelle installation récupérer mes sites ?

je suis sous debian wheezy

8 réponses

mamiemando Messages postés 32067 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 27 janvier 2023 7 536
Modifié par mamiemando le 4/02/2015 à 09:30
Pour "récupérer" un site il faut (outre copier les fichiers que tu as gardé au bon endroit) :

1) Réinstaller le serveur web

Installe ton serveur web et le virtualhost de ton site pour lui indiquer que ton site est dans /var/www. Si tu utilises apache tu peux t'inspirer de ce qui est expliqué ici :
https://www.mistra.fr/tutoriel-linux-serveur-web-apache2.html

2) Réinstaller mysql

a) Supposons que ton backup de /var/lib/mysql soit dans /root/mysql :

mv /var/lib/mysql /var/lib/mysql.old
cp -r /root/mysql /var/lib
aptitude update
aptitude install mysql-server


b) Si tout marche correctement tu peux supprimer /
var/lib/mysql.old
et
/root/mysql
.

3) Attention aux droits !

Normalement les uid des utilisateurs root, mysql, et www-data devraient coïncider. Si c'est le cas, quand tu fais un
ls -l
, les noms d'utilisateurs et de groupes devraient être correctement affichés (le cas échéant, tu verras un entier à la place, correspondant à l'ancien uid, ou pire, l'utilisateur qui désormais correspond à ce nouvel uid). Tu peux les retrouver uid de ces utilisateurs avec la commande :

(mando@velvet) (~) $ egrep "^(root|www-data|mysql):" /etc/passwd | cut -d":" -f1,3

root:0
www-data:33
mysql:115


Si tu observes un problème d'uid, ça se répare, il suffit de faire le
chown
adéquat.

Mais attention, car certains fichiers appartiennent à root (et il ne doivent pas appartenir à www-data ou mysql, sinon tu peux ouvrir un trou de sécurité), ou réciproquement à www-data (resp. mysql) mais il ne faut pas les attribuer à root (sinon tu auras des permissions refusées et ça plantera). En tout cas, surtout pas de
chmod
.

Bonne chance
0
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 135
6 févr. 2015 à 17:55
ok merci
je vais essayer
la seule chose que je n'ai pass pris en compte c'est la reinstallation de mysql-server après la copie/chown des répertoires
0
mamiemando Messages postés 32067 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 27 janvier 2023 7 536
7 févr. 2015 à 01:23
Ok, pense à basculer ce sujet en résolu si tu as toutes tes réponses :)
https://www.commentcamarche.net/infos/25917-marquer-un-fil-de-discussion-comme-etant-resolu/

Bonne chance
0
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 135
7 févr. 2015 à 19:14
salut
ca ne marche pas pour l'instant :

aptitude install mysql-server ne fait rien ( ce qu iest normal )

désintallation/installation : voila ce que donne phpmyadmin :
Requête SQL: DocumentationModifier Modifier

SELECT `db_name` , `comment`
FROM `phpmyadmin`.`pma_column_info`
WHERE `column_name` = '(db_comment)'

MySQL a répondu: Documentation
#1146 - Table 'phpmyadmin.pma_column_info' doesn't exist
La connexion au controluser tel que défini dans votre configuration a échoué.
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 135
Modifié par dindoun le 7/02/2015 à 20:03
donc je continue :

apt-get --purge remove mysql-server.* phpmyadmin
apt-get install mysql-server
apt-get install phpmyadmin

la pour l'instant plus d'erreur
0
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 135
7 févr. 2015 à 20:08
probablement résolu mais encore quelques vérifications :

apt-get --purge remove phpmyadmin
apt-get --purge remove mysql-server.*
rm -r /var/lib/mysql/*
rmdir mysql
mkdir /var/lib/mysql ; cp -a var_lib_mysql/* /var/lib/mysql/ ; chown -R mysql.mysql /var/lib/mysql ; chown root.root /var/lib/mysql/debian-5.5.flag /var/lib/mysql/mysql_upgrade_info ; chown mysql.root /var/lib/mysql/mysql
apt-get install mysql-server
apt-get install mysql-server phpmyadmin
0
dindoun Messages postés 1027 Date d'inscription mercredi 23 janvier 2008 Statut Membre Dernière intervention 17 février 2017 135
7 févr. 2015 à 22:03
ca marche
0
mamiemando Messages postés 32067 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 27 janvier 2023 7 536
8 févr. 2015 à 01:03
Merci pour ton retour, effectivement réinstaller phpmyadmin permettait de résoudre la 2e partie de ton problème.

Bonne continuation !
0