Menu déroulant dynamique ?? [Résolu/Fermé]

Signaler
Messages postés
120
Date d'inscription
lundi 4 mai 2009
Statut
Membre
Dernière intervention
21 janvier 2019
-
Messages postés
120
Date d'inscription
lundi 4 mai 2009
Statut
Membre
Dernière intervention
21 janvier 2019
-
Bonjour,

j ai créé dans une feuille, une liste : adhérents on y retrouve plusieurs lignes avec les noms
une autre liste avec 13 activités pour en faire des menus déroulants
dans une autre feuille je vais avoir
une colonne adhérents, une colonne activité, le prix payé

comment faire pour obtenir le total payé de chaque activité?

merci de votre aide...



2 réponses

Messages postés
25321
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 septembre 2020
5 498
Bonsoir
base de la formule adaptée:

=SOMME.SI.ENS(champ à sommer;champ nom adhérent; "nom adhérent", champ activité,"activité")
vous pouvez remplacer les noms et activités entre guillemets par l'adresse des cellules contenant ces noms, mais alors sans les guillemets

par exemple:

base de données en feuil1:
en A les noms en B les activités, en C les montants

tableau d'édition
le nom en A2 ect...
le titre d'activité en B1

la formule:

=SOMME.SI.ENS(Feuil1!C:C;Feuil1!$A:$A;$A2;Feuil2!$B:$B:B$1)

qui peut se tirer à droite et vers le bas si les signes $ sont bien placés

Cette formule fonctionne à partir de Excel 2007 seulement.

Par contre pour avoir le total d'activité tous adhérents:
=SOMME.SI(feuil1!B$B:B;B$1;Feuil1!$C:$C))



crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
120
Date d'inscription
lundi 4 mai 2009
Statut
Membre
Dernière intervention
21 janvier 2019
72
merci merci merci !!!