Analyse aléatoire

Fermé
KrystelC - 27 janv. 2015 à 21:50
redaiwa
Messages postés
346
Date d'inscription
mardi 7 octobre 2008
Statut
Membre
Dernière intervention
2 juin 2015
- 28 janv. 2015 à 10:01
Bonjour,



J'aimerais me faire une formule qui va me choisir aléatoirement les comptes a analyser par rapport aux montant total du compte.

Exemple

Student 1000 $
École 100 $
Étude 5000 $
Loyer 10000$

Dans c'est chiffre mon student a 1000 chances de se faire analyser, école 100 chances, étude 5000 chances et loyer 10000 chances. De plus, si je décide de choisir aléatoirement 2 comptes si le premier compte est le numéro 1068 sa tombe sur école donc dans mon 2e choix aléatoire le choix 1001 à 1100 (student) ne doit pas pouvoir être choisis.

Est-ce que vous avez une idée comment je pourrais m'en sortir ?

Merci de votre aide

Krystel

1 réponse

redaiwa
Messages postés
346
Date d'inscription
mardi 7 octobre 2008
Statut
Membre
Dernière intervention
2 juin 2015
118
28 janv. 2015 à 10:01
Salam Krystel.

Si j'ai bien compris, on devra tirer un nombre N au hasard entre 1 et 16100 tel que :
- si N est compris entre 1 et 1000 (1000 chances), alors c'est "Student"
- si N est compris entre 1001 et 1100 (100 chances), alors c'est "Ecole"
- si N est compris entre 1101 et 6100 (5000 chances), alors c'est "Etude"
- si N est compris entre 6101 et 16100 (10000 chances), alors c'est "Loyer"

Si c'est bien ça, alors mettre en A1 la formule =ALEA.ENTRE.BORNES(1;16100) et en A2 la formule =SI(A1<=1000;"Student";SI(A1<=1100;"Ecole";SI(A1<=6100;"Etude";"Loyer")))

Maintenant, à chaque appui sur la touche F9, un nombre aléatoire est tiré en A1 et le résultat correspondant est affiché en A2.

Quant au choix aléatoire de deux comptes, je n'ai pas bien saisi ce que tu veux.

J'espère avoir aidé :)
0