Faire une boucle sans VBA

Fermé
lucky-luccio Messages postés 2 Date d'inscription jeudi 8 janvier 2015 Statut Membre Dernière intervention 8 janvier 2015 - Modifié par lucky-luccio le 8/01/2015 à 11:38
lucky-luccio Messages postés 2 Date d'inscription jeudi 8 janvier 2015 Statut Membre Dernière intervention 8 janvier 2015 - 8 janv. 2015 à 20:00
bonjour,
je voudrais écrire une formule excel qui fait le calcul suivant :

Pour i de A1 à A10
faire =somme(sommeprod((B1:B100=1)*(C1:C100=i)))
La plage A1:A10 fait référence à des valeurs.

Je suis quasi sur qu'il est possible de le faire en fonction sans VBA, mais comment ?
Merci pour votre aide

3 réponses

JvDo Messages postés 1978 Date d'inscription mercredi 27 juillet 2005 Statut Membre Dernière intervention 28 septembre 2020 851
8 janv. 2015 à 12:30
Bonjour,

tu peux aussi faire :
=SOMMEPROD((B1:B100=1)*(C1:C100=TRANSPOSE(A1:A10)))

à valider par CTRL+MAJ+ENTER

cordialemment
2