Faire une boucle sans VBA

[Fermé]
Signaler
Messages postés
2
Date d'inscription
jeudi 8 janvier 2015
Statut
Membre
Dernière intervention
8 janvier 2015
-
Messages postés
2
Date d'inscription
jeudi 8 janvier 2015
Statut
Membre
Dernière intervention
8 janvier 2015
-
bonjour,
je voudrais écrire une formule excel qui fait le calcul suivant :

Pour i de A1 à A10
faire =somme(sommeprod((B1:B100=1)*(C1:C100=i)))
La plage A1:A10 fait référence à des valeurs.

Je suis quasi sur qu'il est possible de le faire en fonction sans VBA, mais comment ?
Merci pour votre aide
A voir également:

3 réponses

Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
847
Bonjour,

tu peux aussi faire :
=SOMMEPROD((B1:B100=1)*(C1:C100=TRANSPOSE(A1:A10)))

à valider par CTRL+MAJ+ENTER

cordialemment
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bonjour,

=SOMMEPROD((B1:B100=1)*(C1:C100)*OU(C1:C100=A1;C1:C100=A2;C1:C100=A3;C1:C100=A4;C1:C100=A5;C1:C100=A6;C1:C100=A7;C1:C100=A8;C1:C100=A9;C1:C100=A10))

A+
Messages postés
2
Date d'inscription
jeudi 8 janvier 2015
Statut
Membre
Dernière intervention
8 janvier 2015

Merci JvDo, c'est excellent. ça m'as fait rêvé quand j'ai réussi à faire marcher ta proposition.
Je ne pensais pas qu'on pouvait valider des formules par autre chose que la touche 'entrer'.

Bonne journée et merci pour ton expertise !