Pilotes ATI Radeon Linux Mint 17 pour rendus GPU Blender

Résolu/Fermé
Akelun Messages postés 182 Date d'inscription vendredi 12 septembre 2014 Statut Membre Dernière intervention 19 juin 2022 - Modifié par Akelun le 3/10/2014 à 11:36
Akelun Messages postés 182 Date d'inscription vendredi 12 septembre 2014 Statut Membre Dernière intervention 19 juin 2022 - 3 oct. 2014 à 22:16
Bonjour,

Je suis sur un ordinateur Dell Studio, acheté en Septembre 2010.
Window$ ayant commencé il y a plusieurs années à essouffler mon ordi à petit feu, je me suis mis à Linux, et ne regrette absolument pas ce choix.
Actuellement, je suis sur Linux Mint 17 - Cinnamon edition - 64 bits avec
- Intel Core i7
- AMD ATI Radeon HD 4650
- 4 Go de mémoire

Mon PC est certes assez vieux, mais il tient toujours le coup, même pour des rendus Blender.

Depuis peu, j'ai lu qu'il était apparemment possible (si je ne dis pas de bêtises) de lancer des rendus GPU sur Blender avec les cartes graphiques ATI (avant, on ne pouvait qu'avec des N-vidia). Mais voilà, que ça soit sur Linux ou sur Windows, je n'ai jamais réussi à activer cette possibilité sur mon logiciel.

De plus, j'ai vérifié sur mon gestionnaire de pilotes, et le pilote pour ATI n'était pas présent (ce qui ne me surprend pas vraiment ^^').
Or, quand j'étais sur Mint 16, on m'avait expliqué comment installer les pilotes ATI avec le programme fglrx, mais dès que j'installais ce programme, mon OS entier ne fonctionnait plus. Du coup, j'aimerais savoir :

- fglrx est-il vraiment la seule solution pour installer les drivers ATI sur Linux ? Si oui, comment dois-je m'y prendre, et surtout comment m'assurer de récupérer mon OS comme tel si jamais ça plante ? Si non, quelles sont les autres solutions ?
- Ma carte graphique peut-elle vraiment être utilisée pour lancer des rendus GPU sur Blender et Linux ?

Voilà, si jamais vous savez, merci d'avance pour toute réponse apportée. =)




PS : Je précise que je ne suis qu'un intermédiaire de bas niveau en Linux. Je sais juste faire les installation de l'OS, l'installation de programmes par logithèque et de certains autres par Terminal + des sudo apt-get update / sudo apt-get upgrade, etc... ^^'


A voir également:

2 réponses

Bonjour,
Pour cette carte graphique le driver propriétaire se nomme fglrx-legacy..
Il est normal que tu ne puisses l'installer sur mint 16 et 17 car AMD a arrêté le support pour les cartes des séries 2000 3000 4000 et ne fournit donc plus de mise à jour du pilote pour ces cartes. Merci AMD...
Le seul pilote qui te reste est le pilote libre radeon qui est moins performant que le pilote proprio. Sache que tu peux activer la dpm dans le kernel en passant l'option radeon.dpm=1 dans grub (à partir du kernel 3.11), ce qui améliorera la sensiblement gestion de l'énergie donc gain en autonomie des batteries et aussi moins de chaleur à disperser, les oreilles disent merci.

Si tu as absolument besoin d'utiliser ce pilote, je ne vois que la solution de réinstaller une version plus ancienne de Mint. En fait il existe un paquet non officiel qui permet de l'installer sur ubuntu 12.04 12.10 et 13.04 (a toi de chercher les équivalences avec Mint), qui modifie la version de xorg afin de la rendre compatible avec le driver.
Malheureusement, ça ne fonctionne plus sur les versions postérieures

Voir ce document :
http://doc.ubuntu-fr.org/catalyst#probleme_avec_ubuntu_1204_1210_1304_pour_les_cartes_radeon_hd_2xxx-3xxx-4xxx
2
Akelun Messages postés 182 Date d'inscription vendredi 12 septembre 2014 Statut Membre Dernière intervention 19 juin 2022 46
3 oct. 2014 à 22:16
Oh sérieusement ! C'est bien la première mais surtout la dernière fois que je m'essaye à une ATI. Vive Nvidia, quoi ! ><

Bon bah, j'ai bien compris et entendu ce que vous m'avez dit, et aucune de ces solutions ne me conviennent, mais je crois comprendre qu'il n'en existe pas d'autres, du coup.

En tout cas, merci beaucoup pour cette réponse rapide et précise. Ca m'évitera de continuer de courir après cette chimère de rendu GPU sur mon vieux Dell Studio.

Je marque le sujet comme résolu. ^^'
0