Problème de formule avec si/et/ou [Résolu/Fermé]

Signaler
Messages postés
11
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
13 août 2014
-
Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
-
Bonjour à tous,
je suis désespérément en train de chercher une réponse à ma problématique mais je n'ai rien pu trouver jusqu'à présent...

Je dois afficher un résultat dans une cellule en fonction de différentes conditions, voici le résumé (en essayant d'être précis !) :

Si condition 1 = OUI ET condition 2 = NON : Résultat à afficher = W
Si condition 1 = OUI ET condition 2 =OUI : Résultat à afficher = X
Si condition 1 = NON : Résultat à afficher = 0
Si condition 3 = OUI et condition 2 = NON : Résultat à afficher=Y
Si condition 3 = OUI et condition 2 = OUI : Résultat à afficher= Z

Auriez-vous une idée pour m'aiguiller ?

Merci d'avance !!!

4 réponses

Messages postés
113
Date d'inscription
vendredi 18 juillet 2014
Statut
Membre
Dernière intervention
21 novembre 2014
8
Bonjour,

ça donnerais ça :

=SI(ET(condition1="OUI";condition2="NON";"w";SI(ET(condition1="OUI";condition2="OUI";"x";SI(ET(condition3="OUI";condition2="NON";"y";SI(ET(condition3="OUI";condition2="OUI";"z";0)
Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
64
Salut,

Voici une solution à tester...

=SI(ET(A1="OUI";A2="NON");"W";SI(ET(A1="OUI";A2="OUI");"X";SI(A1="NON";0;SI(ET(A3="OUI";A2="NON");"Y";SI(Et(A3="OUI";A2="OUI");"Z";"")))))

où A1 est la condition1, A2 la condition 2 et A3 la condition 3
Messages postés
11
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
13 août 2014

Bonjour, merci pour vos réponses, malheureusement ça n'a pas l'air de fonctionner...
j'essaie de nouveau ce matin, si vous avez d'autres idées, n'hésitez pas !!!
Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
64
re,

Joins nous ton fichier anonymisé va cjoint.com
Messages postés
11
Date d'inscription
jeudi 6 mars 2014
Statut
Membre
Dernière intervention
13 août 2014

J'ai trouvé ! :-) En fait je devais mettre l'argument SI avec une seule condition à la fin de la formule :

=SI(ET(A1="OUI";B1="NON");A3;SI(ET(A1="OUI";B1="OUI");B3;SI(ET(A1="NON";B1="NON");A7;SI(ET(A1="NON";B1="OUI");B7;SI(A1="NON";0)))))

Merci pour votre aide, vous avez été excellents et m'avez permis de finaliser ce truc qui me rendait fou !!!
Messages postés
569
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
7 mai 2015
64
De rien
Bonne continuation @+