Somme de valeur en fonction d'une colonne et d'une ligne [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
mardi 29 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2014
-
Messages postés
2
Date d'inscription
mardi 29 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2014
-
Bonjour,

Suite à une recherche infructueuse sur le site, je me permets de vous solliciter pour de l'aide sur le sujet suivant :

J'ai un tableau "tableau 1" que je voudrais synthétiser et afficher sous la forme du tableau 2 (voir pj).


Est-il donc possible d'utiliser une formule (sans macro) de somme et de recherche pour récupérer une valeur en fonction du titre d'une colonne et des informations présentes dans les lignes?

J'espère avoir été assez clair... Je vous remercie d'avance pour vos réponses.

Cdlt,

3 réponses

Messages postés
12376
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 juillet 2020
1 922
Bonjour

1) nommer les plages :
A2:A20 noms
B2:B20 mois
C2:C20 HS_Semaine (il faut le _ car les noms de plage n'acceptent pas les espaces
D2:D20 HS_Weekend
E2_E20 Astreinte

2) Remplacer dans tableau 2 tous les HS Semaine par HS_Semaine et HS Weekend par HS_Weekend (car la formule viendra ici lire le nom de la plage de recherche)

3) en C23 mettre la formule :

=SOMME.SI.ENS(INDIRECT($B23);noms;$A23;mois;c$22) en respectant bien les emplacements des $

Étirer la formule sur les lignes et les colonnes

ou si version Excel avant 2007
=SOMMEPROD((noms=$A23)*(mois=C$22)*INDIRECT($B23))

Cdlmnt


1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 62561 internautes nous ont dit merci ce mois-ci

Messages postés
9496
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
7 juillet 2020
1 857
Bonjour

Un exemple
https://www.cjoint.com/?3GDnHevWQu9

Cdlmnt
Messages postés
2
Date d'inscription
mardi 29 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2014

Re-bonjour,

Vos solutions fonctinnement à merveille !!

Merci pour la rapidité et la qualité de vos réponses. Vous m'enlevez une épine du pied.

Une bonne continuation à vous.

Cdlt,