Fonction arrondi pour toute une formule

[Résolu/Fermé]
Signaler
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
-
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
-
Bonjour,

Je voudrais indiquer la fonction arrondi pour toute une formule

J'ai du mal
Voici ce que j'essaie d'arrondir :
=SI(SOMME(E41:E47)-SOMME(E33:E34)=0;"Parfait";"Erreur, A refaire")

J'ai fait cela mais ça ne fonctionne pas :

=SI(SOMME(arrondi(E41;0):arrondi(E47;0))-SOMME(arrondi(E33;0):arrondi(E34;0))=0;"Parfait";"Erreur, A refaire")

Ca ne fonctionne pas et ça me semble bien compliqué,
n'y a t'il pas moyen d'indiquer l'arrondi une seule fois en début de formule ?

Voici ce que j'ai fait aussi qui fonctionne sur une formule plus simple :
=+SI(ARRONDI(B39;0)=ARRONDI(ESS6!E41;0);"OK";"ERREUR FILLETTE")

Merci :)

6 réponses

Messages postés
10161
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 octobre 2021
2 232
Bonjour

Peut être comme ceci
on arrondit la différence des sommes)
=SI(ARRONDI(SOMME(A2:A4)-SOMME(B2:B5);0)=0;"OK";"err")
on fait la difference des arrondis
=SI(ARRONDI(SOMME(A2:A4);0)-ARRONDI(SOMME(B2:B5);0)=0;"OK";"err")

Cdlmnt
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Bonjour

J'ai essayé ça :
=SI(ARRONDI(SOMME(E41:E47)-SOMME(E33:E34);0)=0;"Parfait";"Erreur, A refaire")

et de l'autre façon, mais ça ne fonctionne pas :(

Cdlmnt
Messages postés
54891
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
16 798
Peux-tu préciser ce qui "ne fonctionne pas" ?
Combien vaut SOMME(E41:E47) ?
Combien vaut SOMME(E33:E34) ?
Combien vaut SOMME(E41:E47)-SOMME(E33:E34) ?
Combien vaut ARRONDI(SOMME(E41:E47)-SOMME(E33:E34);0) ?
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Bonjour

Combien vaut SOMME(E41:E47) =0
Combien vaut SOMME(E33:E34) = 0
Combien vaut SOMME(E41:E47)-SOMME(E33:E34) = 0
Combien vaut ARRONDI(SOMME(E41:E47)-SOMME(E33:E34);0) = désolé, nous avons trouvé une erreur dans cette formule, Essayez de cliquer sur Insérer une fonction sous l'onglet Formules, etc etc

:(
Messages postés
54891
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
16 798
Il serait temps que tu envoies ton fichier, parce qu'on ne peut pas deviner où tu as fait des erreurs. J'ai revérifié (par acquit de conscience) et les formules qu'on t'a données sont bonnes !
Mais je ne sais pas ce que tu as jugé bon d'écrire dans ton tableau ...
Va dans http://cijoint.com/ pour créer le lien, que tu reviendras coller ici.
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Bonjour

Voici le lien https://mon-partage.fr/f/i1NqN1Rm/

Merci :)
Messages postés
16527
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
23 octobre 2021
3 232
Bonjour

à adapter
=SI(ARRONDI(SOMME(A2:A10)-SOMME(C2:C10);0)=0;"OK";"NOK")

attention:" l'arrondi de la somme n'est pas égal à la somme des arrondis"
proverbe comptable
Messages postés
54891
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
16 798
Salut coccinelle.

Tu ne travailles pas sur des nombres entiers, mais sur des montants à 2 décimales.
Tu ne dois donc pas écrire ARRONDI(E41;
0
)
mais ARRONDI(E41;
2
)


Les montants en E27:E33, de même que ceux en E41:E47, sont déjà avec 2 décimales ; il est donc inutile de les arrondir !

Le calcul en E35 est parfaitement exact ; il est la référence pour le document et est le seul opposable à des tiers. Tu aurais dû élaborer ce tableau AVANT de régler tous tes honoraires, dont le total dépasse de 1 cent (exactement 0,6 cent) le total TTC affiché en E35, et payer 1 centime de moins à l'un des 7 cotraitants (en toute justice celui qui touche le plus, le N° 2).

Pas la peine de te battre avec les formules et les arrondis, ça ne t'avancera à rien !
La prochaine fois que tu auras à gérer un chantier en cotraitance, pense à indiquer dans tes devis et contrats que les honoraires seront systématiquement arrondis à l'euro (donc des nombres entiers).

P.S. Ce n'est pas par hasard que, dans les déclarations de revenus, tous les montants sont arrondis à l'euro ...

Cordialement.
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Bonjour et merci pour ta réponse Raymond

Concernant ma formule, ce que je souhaite, c'est une vérification qui ne tienne pas compte des centimes.
C'est à dire que je souhaite que ma formule me dise que c'est ok même si il y a 1 centime de différence comme c'est le cas ici.
Voila pourquoi j'ai arrondi avec un 0 et non pas 2.
Peut être y a t'il plus simple pour vérifier dans ce cas la ?

De plus il n'est pas possible d'arrondir à l'euro.

Cordialement
Messages postés
54891
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
16 798
"De plus il n'est pas possible d'arrondir à l'euro" :
Mais oui, c'est exactement ce que tu réalises en faissant "arrondi avec un 0".

Au vu de tes précisions, ta formule sera simplement =SI(ARRONDI(SOMME(E41:E47);0)-ARRONDI(SOMME(E33:E34);0)=0;"Parfait";"Erreur, A refaire")

N.B. 
Je te signale qu'il y a une (importante) différence entre "arrondir 12,85" qui donne 13 et "ne pas tenir compte des centimes" qui donnerait 12, avec la formule =ENT(12,85).
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Hello (me revoila après qq jours de vacances)
Merci pour ta formule, elle fonctionne parfaitement
J'ai bien noté la différence entre arrondir et la formule entier
Merci encore :)
Messages postés
10161
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 octobre 2021
2 232
Re bonjour à tous

C'est à dire que je souhaite que ma formule me dise que c'est ok même si il y a 1 centime de différence comme c'est le cas ici.
Dans ce cas, peut être maximiser la valeur absolue de la différence des sommes
- pour un plafond à 0.01
=SI(ABS(SOMME(E41:E47)-SOMME(E33:E34))<=0,01;"OK";"ERR")
- pour un plafond à 0.1 remplacer 0.01 par 0.1
- pour un plafond à ....

Cdlmnt
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Bonjour
Cette formule fonctionne aussi parfaitement, elle est plus proche je pense, de ma demande.
Elle veut dire que le résultat est ok si le résultat est égal à 0.01 en plus ou en moins,
C'est bien cela ?
Messages postés
10161
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
23 octobre 2021
2 232
Presque
Elle veut dire que le résultat est ok si le résultat est inférieur ou égal à 0.01 en plus ou en moins

Cordialement
Messages postés
87
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
1 décembre 2015
1
Merci beaucoup pour votre aide Raymond et ccm81 :)
Bien cordialement

Martine