Installation windows 7 : "Un pilote de lecteur CD/DVD manque"

Résolu/Fermé
Falkken
Messages postés
6
Date d'inscription
samedi 17 mai 2014
Statut
Membre
Dernière intervention
18 mai 2014
- 17 mai 2014 à 12:42
 Ukki - 26 mars 2017 à 12:34
Bonjour,

Comme beaucoup de monde en ce moment, je dois migrer un ordinateur fixe de Windows XP un OS plus récent. L'ordinateur en question datant un peu (environ 7 ans) et ayant une configuration quelque peu limitée (voir ci-dessous), je me suis tourné vers Windows 7 32 bits.

La configuration :
Processeur : Intel Pentium D CPU 3.40Ghz
RAM : 1 Go
Disque dur : Maxtor STM3160211AS 160GB 7200tr/min


Pour ce faire, j'ai décidé d'utiliser une clé USB bootable. J'avais déjà utilisé cette clé pour installer Windows 8.1 sur un autre PC. La clé a été formatée grâce à Windows 7 USB DVD Download Tool et un ISO Windows 7 32/64bits récupéré sur Dreamspark grâce à mon école. La suite est classique : j'insère la clé, je change l'ordre de boot et je l'ance l'installation.

Problème : après avoir cliqué sur "Installer maintenant", un message apparaît :
"Un pilote lecteur CD/DVD manque. Si vous disposez d'une disquette, d'un CD, DVD ou lecteur flash USB contenant le pilote, insérez le maintenant."

Après avoir effectué quelques recherches, les pistes s'orientent vers une clé mal formatée ou un ISO défaillant. J'ai donc testé avec Unetbootin, puis avec un autre ISO mais le résultat était toujours le même. Autre essai un peu plus radical, j'ai complètement viré le lecteur CD/DVD de la tour et surprise, on me demande toujours le fameux pilote.

J'avoue être un peu à cours d'idées pour résoudre ce problème. Est-ce que vous avez des pistes ?

Merci d'avance.
A voir également:

4 réponses

Falkken
Messages postés
6
Date d'inscription
samedi 17 mai 2014
Statut
Membre
Dernière intervention
18 mai 2014
9
18 mai 2014 à 01:49
Voilà, Windows 7 est installé et tourne bien. Bon, c'est un peu difficile avec 1Go de RAM mais on verra ça plus tard.

J'ai trouvé le message d'erreur en anglais, ce qui m'a permis d'élargir mes recherches et de tomber sur ce post https://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/a-required-cddvd-device-driver-is-missing-usb/61eda679-66cc-4512-b175-d02871394461

En gros, une fois que l'on me demande un driver, il faut annuler la procédure d'installation, retirer la clé, la remettre dans un autre port et relancer l'installation. Miracle, ça marche ! Visiblement, cela serait du au fait que, au moment de lancer l'install, l'utilitaire d'installation perd la liaison avec le port USB sur lequel il a booté.

Quoi qu'il en soit, ça fonctionne. Merci Kinavira pour ton soutien :-).
9
Kinavira
Messages postés
611
Date d'inscription
samedi 16 juillet 2011
Statut
Membre
Dernière intervention
31 décembre 2018
191
18 mai 2014 à 12:16
D'accord très bien, et bien je me coucherais moins bête :)
Au plaisir, bonne continuation :)
0
Je confirme j'ai eu le même problème, remettre la clé usb sur un autre port et le tour est joué
0
Cyrille MPG
11 oct. 2016 à 08:49
je confirme aussi, il faut changer de port... moi je fixais ma clé usb dans un port 3.0 et quand j'ai mis dans un port 2.0 tout est passé...bingo
0
Yeah, j'y croyais plus trop! Sur le mien je n'avais pas d'usb3 donc je peut pas me tromper.

Le fait de changer de port a fonctionné pour moi aussi! bien joué et merci pour la réponse!
0
Kinavira
Messages postés
611
Date d'inscription
samedi 16 juillet 2011
Statut
Membre
Dernière intervention
31 décembre 2018
191
17 mai 2014 à 12:48
Salut,
Je vois pas pourquoi il demande ça mais si t'essaye de rechercher directement le pilote du lecteur CD compatible win7 avec le modèle et la marque de ton ordi il se passe quoi ?
ça coûte rien d'essayer non ? :)

En attente de te lire ;)
1
Falkken
Messages postés
6
Date d'inscription
samedi 17 mai 2014
Statut
Membre
Dernière intervention
18 mai 2014
9
17 mai 2014 à 13:09
Salut Kinavira,

Merci pour ta réponse. Effectivement, j'ai oublié de donner des détails sur le lecteur CD en question. Il s'agit d'un LG GSA-H42N. J'avais en effet tenté de rechercher le pilote mais à en croire la page dédiée sur le site du constructeur (https://www.lg.com/uk/support/product/lg-GSA-H42N il n'y a pas de pilote compatible Windows 7.

Maintenant qu'il est débranché (et n'apparaît plus dans la liste des périphériques lorsque je change l'ordre de boot dans le BIOS), pourquoi me le demanderait-il ?
0
Kinavira
Messages postés
611
Date d'inscription
samedi 16 juillet 2011
Statut
Membre
Dernière intervention
31 décembre 2018
191
17 mai 2014 à 18:07
Très bonne question, j'avoue que j'en sais trp rien.
Est-ce que l'installation par clé usb "émule" un cd dans le lecteur ? je sais pas du tout.
Et en essayant avec un driver compatible xp ? ça marche ?
0
3IR3
Messages postés
864
Date d'inscription
mercredi 27 octobre 2010
Statut
Membre
Dernière intervention
25 avril 2022
221
28 mai 2015 à 00:01
Bonjour à tous,

J'ai eu exactement ce problème et l'astuce citée ci-dessus ne marchait pas pour moi.
J'ai dû aller dans le BIOS et passer "USB 3.0 Configuration in Pre-OS" sur Auto (par défaut il était activé).
Voilà, si ça peut aider quelqu'un.
0
scalpe
Messages postés
742
Date d'inscription
lundi 12 juillet 2004
Statut
Membre
Dernière intervention
23 mars 2020
88
Modifié par scalpe le 10/06/2015 à 14:35
Merci 3IR3 pour cette astuce !!! J'ai bien galéré aussi avec mon Asus R500A ne serait ce que pour entre dans le bios car il sont bloqué d'origine. En voulant passer de W8.1 à W7 je me suis retrouvé avec ce message de pilote cd/dvd manquant. Donc pour moi c'est juste dans configuration USB puis usb pré boot que j'ai désactivé et là miracle plus de messages d'erreur !!! L'installation est parti et quel bonheur de retrouver W7 plutôt que ce daube de 8 !!!
Et merci a l'auteur de ce post qui m'a permis de trouver la solution !!!
0
Merci beaucoup, ça posait aussi un soucis pour Compaq 15-s020nf.
0