Calculer des coûts à partir d'une base de données [Résolu/Fermé]

Signaler
Messages postés
45
Date d'inscription
mardi 25 février 2014
Statut
Membre
Dernière intervention
12 octobre 2017
-
Messages postés
45
Date d'inscription
mardi 25 février 2014
Statut
Membre
Dernière intervention
12 octobre 2017
-
Bonjour,

Pour faire simple, mon fichier excel se compose de 3 onglets :
1- base de données : nom des éléments colonne A et prix correspondant en B
2- nombre d'éléments et état (à changer, ok, etc.)
3-budget à prévoir :
- colonne A rappel des noms des éléments ("='Base de données'!A4", etc.)
- colonne B à H : récapitulatif de chaque état en fonction de l'élément
- colonne I : budget à prévoir = prix x nombre à changer

la base de donnée pouvant évoluer, je voudrais que ma colonne I réfléchisse toute seule. Par exemple si A5=armoire alors I5 va chercher dans la base de donnée le prix d'une armoire et le multiplie avec le nombre d'armoire trouvé dans B5.

Je ne sais pas si je suis très compréhensible...

Quelqu'un voit, comprends et est capable de le faire ?

Merci d'avance !

1 réponse

Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
2 075
Bonjour

1° Nommer toute la plage des colonnes A et B de la base de données par exemple base (selectionner plage clic droit nommer plage)

2° formule en I5 = RECHERCHEV(A5;base;2;0)*B5
à étirer ensuite

Cdlmnt
Messages postés
45
Date d'inscription
mardi 25 février 2014
Statut
Membre
Dernière intervention
12 octobre 2017

Bonjour et merci par avance,

Dans l'onglet base de donnée, j'ai appelé la plage A "base" et la plage B "prix"

En I5 j'ai écrit =RECHERCHEV(A5;base;prix;0)*B5

Mais il me met erreur due à une référence non valide...

Vous avez une idée ?

Merci !!!!
Messages postés
12867
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
29 novembre 2020
2 075
J'ai bien dit de nommer la plage des 2 colonnes A et B ensemble base
RECHERCHEV recherche dans la 1ere colonne de la plage la valeur de A5 et renvoie la valeur de la 2eme colonne correspondante (le 2 dans la formule) soit le prix
Messages postés
45
Date d'inscription
mardi 25 février 2014
Statut
Membre
Dernière intervention
12 octobre 2017

oups effectivement ça marche :)

Encore merci