SI cellule =tel couleur alors texte reporter [Résolu/Fermé]

Signaler
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014
-
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
-
Bonjour à tous,

Une formule me pose problème qui apriori m'avais l'air en 1ère vue abordable!!!
Peut-être pourrez-vous m'aider.
Alors j'ai un tableau Excel sur une feuille nommer 'tableau de suivi' qui comporte plusieurs colonne : nom, prénom, adresse, montant accordé.....
Une fois que j'ai fini de traiter leur dossier je mes ces cellules en une couleur ( peu importe, par exemple vert) ensuite ces cellules je les mets dans un autre tableau (feuille tableau d'attribution)
Donc se que j'aimerais est que SI('tableau de suivi'!C3:G3 est vert alors ='tableau de suivi'! c3:g3)

J'espère que c'est assez clair sinon je mettrai mon fichier

Merci :)

5 réponses

Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
72
Bonjour,

Je vous conseille ici de ne pas laisser la couleur comme critère de vérification. Les couleurs sont une représentation visuelle, pas des variables (même s'il est possible de les utiliser comme des variables de condition). Ainsi, vous pouvez mettre une seconde colonne (que vous pouvez cacher par la suite) qui marque les cellules qui vérifient votre condition.

Si vous tenez absolument à utiliser les couleurs comme critère, c'est moins propre, mais c'est possible. Il faut passer par des macros dans ce cas. ça va ressembler à quelque chose de ce genre :
Public Function myColor(myCell as Range)
    myColor = myCell.Interior.Color
End Function

puis mettre cette fonction dans une cellule qui transformera la couleur en une valeur
=myColor(A1)
. Vous pouvez faire votre critère sur cette valeur.
Messages postés
12379
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 juillet 2020
1 922
Bonjour

Pas de condition possible à partir de la couleur ou alors par programme en VBA

Mais pour faire simple pouquoi ne pas avoir une colonne supplémentaire "Traitement terminé" dans laquelle tu inscris OUI ou X lorsque le dossier est traité:

Le OUI ou le X dans cette colonne servir alors à la fois :
- dans une mise en forme conditionnelle à faire colorer en vert la ligne traitée
- dans une formule SI pour tester ce qui est traité

Cdlmnt
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014

Pourquoi faire compliqué quand on peux faire simple :)

Merci je n'y avait pas pensée!
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014

Par contre petit souci j'ai mit cette formule :

=SI('Tableau de suivi'!B3="X";('Tableau de suivi'!D3);(""))

Sauf que dans mon tableau d'attribution ça me fait des cellules vides et si dans la formule je ne met pas ("") ça me mettra faux alors que je veux que les cellules ou X apparait s'affiche à la suite.
Messages postés
12379
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 juillet 2020
1 922
Enlève les parenthèses en trop dans ta formule :
=SI('Tableau de suivi'!B3="X";'Tableau de suivi'!D3;"")
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014

ça fait toujours pareil:(
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014

Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
72
Si c'est pas trop vous demander, ça serait pas mal de détailler un peu ce que vous avez fait pour soigner l'affichage en liste des listes traitées dans le tableau de suivi.
Messages postés
18
Date d'inscription
jeudi 30 janvier 2014
Statut
Membre
Dernière intervention
25 avril 2014

c'est à dire je ne comprend pas votre demande?
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
72
La demande est destinée à via55 :-)
Je voulais qu'il commente le fichier qu'il a édité. ça peut servir pour d'autres personnes.
Messages postés
12379
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
9 juillet 2020
1 922
J'avais commenté dans la réponse mais peut être pas suffisamment alors voilà un fichier plus simple sur une seule feuille avec le même principe et les explications des formules

https://www.cjoint.com/?DDzozQO09ds

Cdlmnt
Messages postés
666
Date d'inscription
mercredi 24 février 2010
Statut
Membre
Dernière intervention
30 mars 2020
72
Merci :)