Afficher des données en fonction du choix d'une liste déroulante [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
lundi 10 mars 2014
Statut
Membre
Dernière intervention
22 juillet 2014
-
Messages postés
9
Date d'inscription
lundi 10 mars 2014
Statut
Membre
Dernière intervention
22 juillet 2014
-
Bonjour à tous,

J'ai un petit souci et je voudrai savoir si vous aviez des idées pour le résoudre.

Voilà, j'ai une liste déroulante qui contient des dates.
J'ai également créé des onglets qui reprennent chacune de ces dates et contiennent des informations qui leur sont relatives.

Sur la page d'accueil de mon fichier Excel, j'ai mis une liste déroulante et je voudrais que lorsque je sélectionne par exemple "9 avril" dans mon fichier Excel, celui-ci inscrive directement en B3, la valeur B3 de la page 9 avril, etc.

En considérant que B1 est la cellule où le résultat de la liste déroulante apparaît, j'ai pensé écrire en B3 : SI(EXACT(9 AVRIL, B1);'9 avril'!B1;SI(EXACT(10 AVRIL, B2)...
Mais il y a quand même beaucoup de jours dans un mois ! :)

J'pensais qu'une macro pourrait être un bon outil mais je ne suis pas sure de comment l'affilier au menu déroulant.
Auriez-vous une idée de ce que je peux faire ?

Merci d'avance

2 réponses

Messages postés
15266
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
6 août 2020
1 322
Bonjour,

si toujours afficher B3 de l'onglet choisi:

=SI(B1<>"";INDIRECT("'"&B1&"'!B3");"")
Messages postés
9
Date d'inscription
lundi 10 mars 2014
Statut
Membre
Dernière intervention
22 juillet 2014

Bonjour,

Merci pour votre réponse rapide.
Je vais tester ça !

Bon weekend.