Formule SI(ET + délai dépassé [Résolu/Fermé]

Signaler
-
 galilea -
Bonjour,

Je ne suis pas du tout experte en formules Excel et je n'arrive pas à me débrouiller avec ce que je souhaite traduire (voir ci-dessous) : pourriez-vous m'aider ?

Si la date en F2 est supérieure de 31 jours à la date d'aujourd'hui
ET
Si L2 = "Oui" ou "Ne sait pas"
ET
Si A2 = vide

ALORS
Ecrire "A relancer" en rouge en U2

SINON
Ne rien écrire en U2

Merci beaucoup pour votre aide et conseils !

Marine


6 réponses

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
551
Bonjour,

U2=SI(ET(A2="";F2>AUJOURDHUI()+31;OU(L2="Oui";L2="Ne sait pas"));"A relancer";"")

et mettre U2 au format Police rouge.

Cordialement.
Bonjour,

merci beaucoup pour votre réponse rapide !

J'ai saisi la formule indiquée mais U2 reste vide alors que la date en F2 est 17/01/2014 (et qu'elle est bien au format Date), donc supérieure à aujourd'hui +31 jours...

Merci d'avance, bonne journée.
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
551
Bonjour,

C'est normal puisque F2 n'est pas supérieure de 31 jours à la date d'aujourd'hui.
Mais comme je crois comprendre ce que tu souhaites, essaie

U2=SI(ET(A2="";F2+31<AUJOURDHUI();OU(L2="Oui";L2="Ne sait pas"));"A relancer";"")

Cordialement.
Merci beaucoup pour ton aide, cela fonctionne à présent !

Bonne journée !
Re bonjour,

En partant du modèle de formule indiqué ci-dessus, j'ai voulu traduire une autre requête que voici : si la date en Qx est passée (càd < à la date d'aujourd'hui), alors écrire en Wx "A retirer".
J'ai donc saisi, par exemple en W2 : =SI(Q2<AUJOURDHUI();"A retirer";"")
Cela fonctionne mais comment exclure les cas où Qx est vide ? (dans ce cas il ne faut rien en Wx). Avec ma formule, "A retirer" est écrit dans W3 même si Q3 est vide.

Merci beaucoup pour votre aide !!

Bonne journée
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
551
=SI(Q2="";"";SI(Q2<AUJOURDHUI();"A retirer";""))
Merci beaucoup :))