EXCEL comment enlever des lignes avec des 0 [Résolu/Fermé]

Signaler
Messages postés
78
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 mai 2017
-
Messages postés
78
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 mai 2017
-
Bonjour,
mon tableau est le suivant en excel
A1= nom du fournisseur B1= no facture D1= date fact E1= montant fact

UNTEL 1220 2014-04-01 12.36
UNTEL 1220 2014-04-01 -12.36
UNTEL 1220 2014-04-01 5.00
UNTEL 1220 2014-04-01 -5.00
PASE PASE 1300 2014-04-03 10.00
Je voudrais que si la somme du fournisseur en(A1) =0 a la colonne E1 alors delete toute les lignes du fournisseur comment puis-je faire s.v.p. Merci beaucoup de votre aide!

3 réponses

Messages postés
5482
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
10 août 2020
464
Bonjour

Sélectionner les titres des colonnes
Allez dans données
Filtrer mettre le filtre
sélectionner la colonne E cliquer sur la flèche du filtre
désélectionner tout puis sélectionner les lignes à zéro
A l'aide des numéro de ligne sélectionner les lignes apparentes cliquer droit supprimer
Allez colonne E enlever le filtre en sélectionnant tout
Voilà les lignes à zéro ne figurent plus sur votre feuille
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
477
Bonjour Marie Chant,
Bonjour PHILOU10120,

Je n'ai pas interprété ta question comme PHILOU10120.
Pour connaitre la somme des montants pour chaque fournisseur, tu peux placer la formule suivante en E1.
=SOMME.SI($A$1:$A$100;A1;$D$1:$D$100)
Ensuite, tu fais une copie avec la poignée de recopie sur toute la colonne E.
Tu visualises ainsi les fournisseurs dont les montants s'annulent, la formule renvoyant alors zéro.
Il te reste à filtrer la colonne avec ces zéros et supprimer les lignes concernées.

A+
Messages postés
78
Date d'inscription
lundi 24 mars 2014
Statut
Membre
Dernière intervention
18 mai 2017

Merci beaucoup cela fonctionne tres bien