Comparer 2 chaines de caractères [Fermé]

Signaler
Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014
-
Messages postés
1938
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
11 mai 2020
-
Bonjour à tous,
J'ai un petit souci sous Excel (problème que j'ai pas pu résoudre en regardant dans les autres posts).
Pour simplifier, je voudrais comparer une phrase avec une référence et avoir en résultat si ma référence est contenue dans ma phrase.
Donc petit exemple, pour expliciter :

colonne 1 : Petit avion - 5364A46 - Airbus
colonne 2 : 5364A46

On aurait donc un OUI en résultat, et si possible regrouper mes résultats dans une autre feuille (ac le nombre de OUI et non).


merci d'avance pour vos réponses,

bonne soirée

Seimeon

3 réponses

Messages postés
1938
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
11 mai 2020
134
Bonjour,

Utiliser les fonctions SI et TROUVE :
SI(TROUVE(B2;A2)>0;"OUI";"NON")

A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63753 internautes nous ont dit merci ce mois-ci

Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour

exact, Zoul

Il est toutefois possible d'accéder directement au résultat avec:

=NB.SI(A:A;"*"&B1"*")

qui comptera directement le nombre de texte de la colonne A qui contiennent le texte inscrit en B1

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63753 internautes nous ont dit merci ce mois-ci

Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014

Merci à vous 2 pour vos réponses.
Cela fonctionne bien.

Dernière question : Comment afficher ma case en vert si le résultat est OUI (et rouge pr NON), je sais qu'on peut le faire case par case, mais je voudrais généraliser ces résultats conditionnels.

bonne journée
Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014

Yes, merci pour ta réponse.

Par rapport à ma première question : j'ai appliqué la formule qui fonctionne bien.
Mais parfois quand je devrais avoir le résultat NON, j'ai le résultat #VALEUR! que je voudrais modifier.
Messages postés
1938
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
11 mai 2020
134
Pardon, j'ai un Excel anglais donc je n'avais pas testé.
Je pensais que TROUVE renvoyait 0 si la chaîne n'était pas trouvée, mais non...
SI(ESTNUM(TROUVE(B2;A2));"OUI";"NON")