Comparer 2 chaines de caractères

Fermé
Seimeon
Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014
- 17 mars 2014 à 16:35
Zoul67
Messages postés
1954
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
3 février 2022
- 18 mars 2014 à 10:18
Bonjour à tous,
J'ai un petit souci sous Excel (problème que j'ai pas pu résoudre en regardant dans les autres posts).
Pour simplifier, je voudrais comparer une phrase avec une référence et avoir en résultat si ma référence est contenue dans ma phrase.
Donc petit exemple, pour expliciter :

colonne 1 : Petit avion - 5364A46 - Airbus
colonne 2 : 5364A46

On aurait donc un OUI en résultat, et si possible regrouper mes résultats dans une autre feuille (ac le nombre de OUI et non).


merci d'avance pour vos réponses,

bonne soirée

Seimeon

A voir également:

3 réponses

Zoul67
Messages postés
1954
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
3 février 2022
147
17 mars 2014 à 16:41
Bonjour,

Utiliser les fonctions SI et TROUVE :
SI(TROUVE(B2;A2)>0;"OUI";"NON")

A+
1
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 254
17 mars 2014 à 17:28
Bonjour

exact, Zoul

Il est toutefois possible d'accéder directement au résultat avec:

=NB.SI(A:A;"*"&B1"*")

qui comptera directement le nombre de texte de la colonne A qui contiennent le texte inscrit en B1

crdlmnt
1
Seimeon
Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014

18 mars 2014 à 09:26
Merci à vous 2 pour vos réponses.
Cela fonctionne bien.

Dernière question : Comment afficher ma case en vert si le résultat est OUI (et rouge pr NON), je sais qu'on peut le faire case par case, mais je voudrais généraliser ces résultats conditionnels.

bonne journée
0
Zoul67
Messages postés
1954
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
3 février 2022
147
18 mars 2014 à 09:48
0
Seimeon
Messages postés
6
Date d'inscription
lundi 17 mars 2014
Statut
Membre
Dernière intervention
20 mars 2014

18 mars 2014 à 10:07
Yes, merci pour ta réponse.

Par rapport à ma première question : j'ai appliqué la formule qui fonctionne bien.
Mais parfois quand je devrais avoir le résultat NON, j'ai le résultat #VALEUR! que je voudrais modifier.
0
Zoul67
Messages postés
1954
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
3 février 2022
147
18 mars 2014 à 10:18
Pardon, j'ai un Excel anglais donc je n'avais pas testé.
Je pensais que TROUVE renvoyait 0 si la chaîne n'était pas trouvée, mais non...
SI(ESTNUM(TROUVE(B2;A2));"OUI";"NON")
0