Excel : compter des lignes si valeur égale dans 2 colonnes [Résolu/Fermé]

Signaler
-
Messages postés
25410
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
-
Bonjour,

sur un tableau excel, je souhaite, ligne par ligne, compter le nombre de cellules qui ont la même valeur dans la colonne M. Pour cela j'utilise la formule suivante qui marche à merveille :

=SI(ESTERREUR(EQUIV($M2;$M$2:$M$60166;0));0;NB.SI($M$2:$M$60166;M2))

maintenant je souhaite ajouter une précision et compter le nombre de cellules de la colonne M qui ont la même valeur UNIQUEMENT SI elles ont d'abord la même valeur (numérique) dans la colonne B.

Quelqu'un saurait-il comment construire cette formule?

D'avance merci beaucoup !



3 réponses

Messages postés
25410
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
5 545
Bonjour

exemple pour un champ de A1 à A1000, à adapter:

=SOMMEPROD((A1:A1000=B1:B1000)*(A1:A1000<>""))

qui compte le nombre de lignes ayant la même valeur en A et B, sauf si A est vide.


Ou alors selon besoin,si vous voulez ne compter que les lignes ayant la valeur de C1 dans A et B sur la ,même ligne

=SOMMEPROD((A1:A1000=B1:B1000)*(A1:A1000=C1))

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
25410
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
5 545
Re

pas sur d'avoir tout compris, mais au moins on avance un peu dans les explications.. du moins je crois!!
reste plus qu'à savoir le rapport entre 18 le fait que la valeur doit exister en J12???

essayons avec B18 et J18 (?), en démarrant en B1 et en tirant sur la hauteur utile

=SOMMEPROD($B$1:$B$1000=B1)*($J$1:$J$1000=J1))

valable pour des champs de ligne 1 à 1000

et qui donnera sur la ligne 18
=SOMMEPROD($B$1:$B$1000=B18)*($J$1:$J$1000=J18))

qui compte combien de fois la valeur de B18 se retrouve en B avec la valeur de J18 sur la même ligne.
Renverra 0 si ce cas de figure n'existe pas.


si ça ne va pas toujours pas, pour qu'on solde la question, mettez un petit modèle avec explications sur les résultats attendus sur ce site:

https://www.cjoint.com/
en revenant ici placez le lien donné par le site.

crdlmnt




1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Ca marche aussi merci pour votre temps !!
et oui en effet c'était 18 et pas 12 :p désolée !
Messages postés
25410
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2020
5 545
Pas de quoi, bonne route.
crdlmnt
Bonjour,

je n'ai malheureusement pas l'impression que ça résolve mon problème.

Autrement dit, je voudrais dans une colonne L obtenir l'info suivante ligne par ligne :

Je souhaite savoir si la valeur que j'ai en B existe en B sur une autre ligne ET SI si on regarde ces deux lignes là si les valeurs en J sont également les mêmes.

Plus clairement, si je me positionne en L18, je veux savoir si la valeur B18 (1025) se retrouve ailleurs en Bqqch ET si la valeur en J12 (180578) existe sur une ligne sur laquelle BX vaut aussi 1025.

Et du coup l'information que je voudrais en L est : combien de fois ce doublon existe-t-il ? (0, 1 ou plus) C'est ce que je voulais compter avec NB.SI

Pouvez-vous m'aider ? :S
Messages postés
12781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2020
2 045
Bonjour annsoph
Bonjour Vaucluse

Si je comprends bien ce que tu veux (nombre de doublons de paire identiques en colonnes B et J) :
pour une plage B2:B10 et J2:J10
soit la formule : =NB.SI.ENS($B$2:$B$10;B2;$J$2:$J$10;J2)
soit la formule : =SOMMEPROD(($B$2:$B$10=B2)*($J$2:$J$10=J2))

Cdlmnt
parfait ça marche super merci beaucoup !!! :D